Screen tinted green using RX 580 + AMDGPU

When using AMDGPU on my computer with my RX 580, everything is very heavily tinted green. This doesn’t seem to just be an EndeavourOS issue either, as I’ve also had this happen on Void Linux, Fedora, Manjaro, and Linux Mint, and it’s always started the moment AMDGPU kicks in. It even happens in the setups for any distro I’ve tried out. There doesn’t seem to be anything else wrong – aside from the colour issues, everything displays just fine, and 3D works just fine (though all I really tried was Tux Racer, plus Frozen Bubble 2 though that game barely has any 3D).

Here’s my relevant system information:

System:    Kernel: 5.13.12-arch1-1 x86_64 bits: 64 compiler: gcc v: 11.1.0 Desktop: Xfce 4.16.0 
           tk: Gtk 3.24.29 wm: xfwm dm: LightDM Distro: EndeavourOS base: Arch Linux 
Machine:   Type: Desktop Mobo: Micro-Star model: B450-A PRO (MS-7B86) v: 2.0 serial: <filter> 
           UEFI: American Megatrends v: A.80 date: 07/09/2019 
CPU:       Info: 8-Core model: AMD Ryzen 7 2700 bits: 64 type: MT MCP arch: Zen+ rev: 2 cache: 
           L2: 4 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 102442 
           Speed: 1886 MHz min/max: 1550/3200 MHz boost: enabled Core speeds (MHz): 1: 1886 
           2: 2799 3: 1271 4: 1273 5: 1376 6: 1492 7: 2538 8: 1643 9: 1275 10: 1297 11: 1374 
           12: 1320 13: 2637 14: 1377 15: 2449 16: 2732 
Graphics:  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] 
           vendor: Sapphire Limited Nitro+ driver: amdgpu v: kernel bus-ID: 29:00.0 
           chip-ID: 1002:67df 
           Display: x11 server: X.org 1.20.13 compositor: xfwm4 driver: loaded: amdgpu,ati 
           unloaded: fbdev,modesetting,vesa resolution: <missing: xdpyinfo> 
           Message: Unable to show advanced data. Required tool glxinfo missing. 

I’m also using a VIZIO VX200E as my monitor, if that’s at all helpful.

I’m frankly completely unsure how to go about fixing this, this isn’t my first rodeo using Linux by far, but this is somewhat my first rodeo using Linux on anything that’s not a laptop (ignoring past times I’ve installed Linux on this PC, seen this, done a bit of research and then decided to come back to this later). AMDGPU doesn’t seem to be producing any errors on boot, and I can’t really find anyone else who’s had this problem.

I don’t have any similar hardware, so I can’t help much.
But have you read this: https://wiki.archlinux.org/title/AMDGPU
It contains lots of information and troubleshooting tips.

and if you disable the composition, does it also have green ? mayby is because the vblank mode is on auto mayby libxpreset or off is better.

look if you disable the compositor if its gone.

Much of that looks similar to mine - but I don’t see a coupole of things in yours. Here’s my inxi -G for comparison (might help set a direction for search)

┌04:43:24 WD= [~]
└───freebird@nest ─▶$ inxi -G
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] driver: amdgpu 
           v: kernel 
           Display: x11 server: X.Org 1.20.13 driver: loaded: amdgpu,ati unloaded: fbdev,modesetting,vesa resolution: 
           1: 3840x2160~60Hz 2: 1800x2400~60Hz 
           OpenGL: renderer: Radeon RX 580 Series (POLARIS10 DRM 3.42.0 5.14.12-zen1-1-zen LLVM 12.0.1) v: 4.6 Mesa 21.2.4 

Where’s your OpenGL and Mesa info, for instance? And your resolution and renderer info for that matter…?

/home/ringo ->inxi -G
Graphics: Device-1: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] driver: amdgpu
v: kernel
Display: server: X.Org 1.20.13 driver: loaded: amdgpu resolution: 1: 2560x1080 2: 1680x1050~60Hz
OpenGL: renderer: Radeon RX 580 Series (POLARIS10 DRM 3.42.0 5.14.12-AMD LLVM 12.0.1) v: 4.6 Mesa 21.2.4
/home/ringo →

mine

@ngoomie
Have you tried uninstalling xf86-video-ati and reboot. The only other reason i could see this maybe is a bad cable or connection. I would power off and undo the monitor connection at both ends and re-attach then if still same try another cable if you have one.

Tried both uninstalling xf86-video-ati and disabling the compositor but no dice. I wasn’t really expecting disabling the compositor to do anything because the green starts being a problem during boot when there’s still nothing but console output, but only after it switches to the proper resolution (hence why I’m sure it happens right as AMDGPU starts running).

I fiddled around with some of the troubleshooting stuff on the Arch wiki, but I’ll go back over it and try some other things out and see if that fixes anything. Reseating the HDMI cable also didn’t do anything, will have to dig around for another cable to try out (I’m sure I have one not already in use somewhere, I’m just not really sure where).

Also, here’s the proper inxi -G output after I installed the missing glxinfo and xorg-xdpyinfo

Graphics:
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] 
  driver: amdgpu v: kernel 
  Display: x11 server: X.Org 1.20.13 driver: loaded: amdgpu 
  unloaded: fbdev,modesetting,vesa resolution: 1600x900~60Hz 
  OpenGL: renderer: Radeon RX 580 Series (POLARIS10 DRM 3.42.0 
  5.14.12-arch1-1 LLVM 12.0.1) 
  v: 4.6 Mesa 21.2.4
1 Like

Have you also tried another monitor just to make sure it isn’t that?

Have you tried setting the resolution differently to see if it makes a difference? I understand you have a 1600x900 monitor, but Settings should let you try other settings, and xrandr definitely will.

I am leaning toward a cable or port problem myself (having seen the correct inxi -G now)…

All relevant amdgpu code is in the kernel. Have you tried a newer kernel?

And what about cabling? How is the monitor connected? Can you try a different cable?

Well, it’s definitely the monitor. I found another cable to test out, and had the same problem with that when connected up to the same monitor, but when hooked up to my TV (thank goodness the cable I snagged was just long enough to do that without lugging my PC around), the picture was completely normal. I’m relieved to now know the issue is fixable, but it sucks too because I won’t be able to buy a new monitor for a while now, and I don’t have any spares lying around. I’ve waited out using Linux on this PC for this long already though, a little while longer isn’t gonna hurt lol

Still, what a strange issue. Literally everything else I’ve tried on this PC works, like multiple versions of Windows and any time Linux is just using the generic display driver.

idd saw this too https://androidnature.com/fix-vizio-tv-green-screen-issue/

weird

Well i didn’t think it was a driver issue. amdgpu is amdgpu. I figured it had to be a cable or the monitor. I have an RX 590 with no issues.

Did you overlook this question?

5.13 is EOL and hasn’t been updated for quite some time.

I didn’t overlook it, I just forgot to directly respond to it, sorry! I did update my kernel and it didn’t do anything either.

HOWEVER, I did finally find a solution! I ended up changing the pixelformat with a custom EDID. I very roughly followed this tutorial, some things varied for me:

This is, admittedly, a potential solution I found very early on. I just disregarded it because most of what I’d heard people describing happening to them with the wrong pixelformat was just crushed blacks and washed out colours, not something as extreme as everything being tinted green.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.