Screen tearing on i3wm

I’ve been experiencing screen tearing on i3wm for a while and I can’t seem to be able to figure out the source. I’ve checked that the refresh rate of xrandr matches the one of my monitor, I’ve made sure that I’ve got the drivers I need installed (at least that I know of, manually installed xf86-video-intel on top of what came with base installation), and I doubt it could be a compositor issue given that I haven’t done anything to it and no one else seems to be having the same issue.

I mostly notice this when I’m scrolling on news websites and other websites that has a lot of text when my screen starts being distorted here and there in horizontal lines. This is not an issue I have on KDE Wayland or KDE X11 but exclusively on i3wm.

Any and all help is appreciated.

system info dump

                   ./sssso-                ----------------- 
                 `:osssssss+-              OS: EndeavourOS Linux x86_64 
               `:+sssssssssso/.            Host: 20X2S0DL00 ThinkPad L14 Gen 2 
             `-/ossssssssssssso/.          Kernel: 6.2.8-arch1-1 
           `-/+sssssssssssssssso+:`        Uptime: 5 mins 
         `-:/+sssssssssssssssssso+/.       Packages: 1384 (pacman), 6 (flatpak) 
       `.://osssssssssssssssssssso++-      Shell: bash 5.1.16 
      .://+ssssssssssssssssssssssso++:     Resolution: 1920x1080 
    .:///ossssssssssssssssssssssssso++:    WM: i3 
  `:////ssssssssssssssssssssssssssso+++.   Theme: Breeze [GTK2], Arc-Darker [GTK3] 
`-////+ssssssssssssssssssssssssssso++++-   Icons: Papirus-Dark [GTK2/3] 
 `..-+oosssssssssssssssssssssssso+++++/`   Terminal: xfce4-terminal 
   ./++++++++++++++++++++++++++++++/:.     Terminal Font: Source Code Pro 10 
  `:::::::::::::::::::::::::------``       CPU: 11th Gen Intel i3-1115G4 (4) @ 4.100GHz 
                                           GPU: Intel Tiger Lake-LP GT2 [UHD Graphics G4] 
                                           Memory: 1495MiB / 7598MiB

[runarcn@endeavour ~]$ xrandr --query
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
eDP1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 310mm x 170mm
   1920x1080     60.05*+
DP1 disconnected (normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)
DP3 disconnected (normal left inverted right x axis y axis)
DP4 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)
GPU: Intel Tiger Lake-LP GT2 [UHD Graphics G4] 

should be gen 6 intel gpu so it should not need the xf86-video-intel package what is only usefull for pre gen 4 gpu chipsets.

that is the browser what is in case a different thing as what would be general tearing… is tearing happen also in playing video files with mpv or such?

In general two things could get tweaked:

  1. set tearfree otion for the gpu driver:
  1. Hardware Accelleration support packages:

For your Browser it may need to force the use of its hardware acceleration in browser settings:

Could be your compositor? I assume you use some version of picom? If so which flavor? Try killing it. Do you still get tearing without it running at all?

I used to get all kinds of graphic glitches and tearing and whatnot until I went back to the original version. There’s also a lot of config files out there that don’t specify which version they used and so have incorrect options set. So I deleted my config and went to correct source for a new template to mod one option at a time.

I’ve done the in-browser tweaks which sadly didn’t fix the issue. The other options seemed at little bit advanced for me to understand just now, so I’ll have to take some time to look into it. Thanks!

I’m gonna be frank and say that I honestly don’t know which compositor it is that I’m using. I’ve clearly got some reading up to do for now, but this seems like a nice place to start. Thanks!

1 Like

You may use none or picom but if you do not installed picom you will not use any composite

do you installed picom?

welcome… but do not enter old threads create new one and get the answer you need :wink: :enos:

1 Like