Screen Tearing on AMD Drivers

So, I have been using Endevouros with little problems, but after connecting to an external monitor, the screen started tearing really bad. I thought it was just the monitors problem, so I disconnected it and rebooted the computer. The tearing remains! Here is an inxi --full output:

  Host: robert-inspiron3541 Kernel: 6.3.1-arch1-1 arch: x86_64 bits: 64
    Desktop: KDE Plasma v: 5.27.4 Distro: EndeavourOS
  Type: Portable System: Dell product: Inspiron 3541 v: N/A
    serial: <superuser required>
  Mobo: Dell model: Inspiron 3541 v: A01 serial: <superuser required>
    UEFI: Dell v: A01 date: 04/28/2014
  ID-1: BAT0 charge: 11.1 Wh (100.0%) condition: 11.1/41.4 Wh (26.9%)
  Info: quad core model: AMD A6-6310 APU with AMD Radeon R4 Graphics bits: 64
    type: MCP cache: L2: 2 MiB
  Speed (MHz): avg: 1975 min/max: 1000/1800 cores: 1: 1975 2: 1975 3: 1975
    4: 1975
  Device-1: AMD Mullins [Radeon R4/R5 Graphics] driver: radeon v: kernel
  Device-2: Sunplus Innovation Integrated_Webcam_HD type: USB
    driver: uvcvideo
  Display: x11 server: X.Org v: 21.1.8 driver: X: loaded: radeon
    unloaded: modesetting dri: radeonsi gpu: radeon resolution: 1280x720~60Hz
  API: OpenGL v: 4.5 Mesa 23.0.3 renderer: KABINI ( LLVM 15.0.7 DRM 2.50
  Device-1: AMD Kabini HDMI/DP Audio driver: snd_hda_intel
  Device-2: AMD FCH Azalia driver: snd_hda_intel
  API: ALSA v: k6.3.1-arch1-1 status: kernel-api
  Server-1: PipeWire v: 0.3.70 status: active
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169
  IF: enp2s0 state: down mac: b8:2a:72:c0:f6:19
  Device-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
    driver: ath9k
  IF: wlan0 state: up mac: 64:5a:04:7d:8d:eb
  Device-1: Qualcomm Atheros AR9462 Bluetooth type: USB driver: btusb
  Report: rfkill ID: hci0 rfk-id: 2 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: see --recommends
  Local Storage: total: 465.76 GiB used: 69.63 GiB (15.0%)
  ID-1: /dev/sda vendor: Samsung model: SSD 860 EVO 500GB size: 465.76 GiB
  ID-1: / size: 97.66 GiB used: 9.33 GiB (9.6%) fs: btrfs dev: /dev/sda5
  ID-2: /boot/efi size: 96 MiB used: 34.9 MiB (36.4%) fs: vfat
    dev: /dev/sda1
  ID-3: /home size: 130.46 GiB used: 60.27 GiB (46.2%) fs: ext4
    dev: /dev/sda7
  ID-4: /var/log size: 97.66 GiB used: 9.33 GiB (9.6%) fs: btrfs
    dev: /dev/sda5
  ID-1: swap-1 type: partition size: 7.81 GiB used: 0 KiB (0.0%)
    dev: /dev/sda6
  ID-2: swap-2 type: zram size: 6.71 GiB used: 0 KiB (0.0%) dev: /dev/zram0
  System Temperatures: cpu: 54.0 C mobo: 43.0 C gpu: radeon temp: 55.0 C
  Fan Speeds (RPM): cpu: 3067
  Processes: 205 Uptime: 5m Memory: 6.71 GiB used: 2.92 GiB (43.6%)
  Shell: Bash inxi: 3.3.26

I tried updating the system and rebooting and nothing worked.

Someone came up with a potential solution on this forum, already:

1 Like

Thank You, even though my solution isn’t the same as that, I found that KDE automatically switched my resolution to the 2nd screen’s resolution. I ended up switching back and it worked

1 Like

That is great! :v:

…and yes, this forum does have a search-function! :wink:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.