Screen Tearing issues on i3 - 12th gen Intel


I am afraid this one will be really hard to troubleshoot but i thought I’d give it a shot anyways. I got myself a new Framework Laptop with an Intel i5-1240P and i instantly installed EndeavorOS on it.
However, i quicky ran into an issue with VSCode and alacritty, both applications were not responing / only showing freeze frames on startup. I eventually traced it down to xf86-video-intel.
I removed xf86-video-intel as suggested in the Arch Wiki for Intel Graphics. This resolved my issues with VSCode and Alacritty.

However, i noticed screen tearing. This was especially notable (and annoying) when switching Desktops in i3 or scrolling through a web page. This happend on my external monitor as well as the integrated display. I resorted to installing KDE and interestingly, on KDE there is no screen tearing for me whatsoever.

Other than removing xf86-video-intel i am on stock EndeavorOS with KDE and i3.

Did you enable the TearFree option?

and try this setting in picom.conf:

vsync = true;

Thank you for your quick reply!

I created the file /etc/X11/xorg.conf.d/20-intel.conf as suggested.

Section "Device"
  Identifier "Intel Graphics"
  Driver "intel"
  Option "TearFree" "true"

However, then i could not boot anymore, boot was freezing after [OK] Started Accounts service.
I used tty to delete the file to be able to boot again.
To my knowledge, picom is not intalled on my system (and all lines regarding picom are commented out in the default i3 configuration).

Cuuld you run
inxi -Faazy --no-host | eos-sendlog
and paste the url it spits out here, maybe that gives us some info that might be helpful and someone can help you out.

Notably, i switched from KDE to XFCE.

You have to stabilize your DE :wink: . The issue you are trying to solve is related to GPU configuration and the compositor you are using.
For xfce4, check proposed troubleshooting for xfwm.
For i3, figure out which is your compositor, and troubleshoot on that.

1 Like

I installed picom and now everything is working as expected. Thank you very much for heping!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.