Screen Tearing after System Update


I updated my System yesterday after a month and now I encounter my screen tearing and flickering after a few minutes of Startup. I am using the i3 version of Endeavour OS.

I have tried reducing the Refresh Rate and creating my own modelines but the problem still persists. Below I am adding my neofetch and xrandr output.

Any help is appreciated.

inxi -Gaz would be interesting to see…
And very welcome here :enos:

Lets see if we can fix this fast!


pacman -Qs xf86-video

would be interesting.

user gone back to windows :wink:

Hi there!

Thank you for the quick replies. I was caught up in Schoolwork.

I executed both commands:

inxi -Gaz:

pacman -Qs xf68-video

Thank you for helping!

At least you shouldn’t need xf86-video-ati, so feel free to uninstall it.

I did that a minute ago and rebooted.

The issue still persists sadly.

Thank you for your time.

Does the problem occur also with the LTS kernel?
If not, then it can be a glitch of the default kernel, and a fix may be coming after some time, provided someone has reported this to the kernel devs.

I don’t really know how to switch Kernels. I googled it but I’m afraid if the instructions apply to Endeavour. Is there an easy way to do it on endeavour?

sudo pacman -Syu linux-lts linux-lts-headers
…and reboot.


1 Like

could be also picom is an issue… i can not use the default package here … but i am running older AMD radeon card…

local/picom-tryone-git 1851_Next.570.gcee1287_2023.01.29-1
    tryone144's picom fork with dual_kawase blur, an X compositor (fork of compton)

and still no clue if it is running on the igpu ?
looks like an art gallery to me Cezanne and Renoir are both Impressionist ? :wink:

Cezanne is the codename of AMD’s Ryzen 5000 series of mobile and desktop APUs based on the Zen 3 CPU and Vega GPU microarchitectures succeeding the Ryzen 4000 “Renoir” series.

Hey all!

Thank you so much for your help. It turned out to be a picom issue. I disabled it (for now) and everything is working perfectly again. I am so sorry for wasting your time with a silly issue! Should’ve been my first or second thought. Thank you so much for your help :slight_smile:

you where nmot wasting tiome… and issue is not really solved :wink:
If it works without picom you may have the same issue as i do have here… you can try using alternative picom version like i do… but indeewd if yoiu do not mind transparfency… you can go without this

When I have time I will look at your alternative picom but for now im just happy to be able to use my laptop again :smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.