Screen stops working after update, reinstall does not fix

I have been using EOS for almost a year now and have been incredibly happy with the distro. However, I have finally run into a problem I can’t fix… About a week ago, I updated my system with yay as usual. I made the mistake of doing this while zoom was running (although I must say that never was a problem before) and zoom crashed and would not start after. I restarted the computer, and one of my three screens just stayed completely black. The situation was the following:

  • The screen has a signal for a very short time while booting. In fact, disconnecting all other screens causes the boot text to appear correctly on that screen, but it turns black as soon as the DM starts.
  • As soon as lightdm starts and I’m in the login screen, it stops working completely (no matter what other screens are connected).
  • The screen is completely black and goes into power saving mode.
  • The screen is recognized by xrandr and can be moved by arandr.
  • The screen is recognized by nvidia-settings and can be moved, framerate changed etc.
  • Changing resolution and framerate via xrandr, arandr or nvidia-settings does not fix the problem.
  • Both the USB headset plugged into the screen as well as the integrated camera work, but it is connected via an additional USB cable.
  • The problem seems to be the specific output - switching my cables around makes that screen work, but the one that is now connected to that output (DVI-D-0) stops working with the same symptoms. This happens no matter if I use a DVI cable or an DVI-to-HDMI adapter and an HDMI cable (I tried with two adapters and two cables of each kind).
  • Connecting my laptop to the same screen works flawlessly (probably the same reason as above).
  • Launching in fallback mode does not fix the problem either.

After all this yielded no results, I opted to reinstall the entire system. I backed up my data and burned an iso. In the live environment, all three screens worked perfectly, giving me hope. However, as soon as the installation finished, the screen stopped working again.
I reinstalled three times with different settings:

  • i3 with my preferred minimal settings (no eos-welcome etc.)
  • i3 with default settings otherwise
  • KDE plasma with full default settings
    each time I chose the ‘erase disk’ option, hoping that whatever was messing up the output would be erased and replaced. Everytime the screen/output worked in the live environment but not in the finished installation (with the same symptoms - gets recognized by settings/xrandr but shows only black).

Some of my system statistics:

  • Intel i7-10700K CPU
  • Nvidia GeForce 750Ti GPU
  • The output in question is DVI-D-1
  • LightDM display manager
  • i3wm window manager
  • I installed with symstemd everytime.
  • Latest EOS & arch kernel version (ISO was downloaded & burned yesterday)

Has anyone encountered this problem before or have any idea what the problem could be? I didn’t find anything on the internet with this specific issue, and all the slightly related fixed I found did not help. Maybe this is something GPU-internal and the live env does not use my Nvidia-GPU? Thanks in advance!

Perhaps try downgrading your Nvidia driver to v550, at least to see if it’s the recent update causing the issue. Your 2013 Nvidia GPU is just scraping in on the claimed supported hardware for that driver.

The command may look something like:

sudo downgrade nvidia-dkms nvidia-utils
1 Like

Sadly that stops my system from working completely, EOS gets stuck in the Started Account Services step of booting and I had to chroot in from my live medium and re-update the nvidia dependencies to save it.

But yeah, the live environment still has v550 for all the nvidia-related stuff… So maybe that could be an avenue for a solution. I will try some different versions tomorrow, maybe one of them works?

1 Like

I’m glad you were able to recover from that :face_exhaling:

A similar suggestion had fixed a stuttering issue for another user, so I thought it worth mentioning.

1 Like

I was finally able to resolve the issue - I noticed I had not nvidia-dkms but nvidia installed, so when downgrading it desynced from my kernel version, causing the crash on boot. Uninstalling nvidia, installing nvidia-dkms and then downgrading both nvidia-dkms and nvidia-utils to a v550-version finally fixed the second output.
Thanks for the help, I could really have solved that with less of a hassle. Do you know if I am now forever doomed to stay on the same driver version, or will newer version maybe solve this issue?

There’s perhaps two questions there, and I’m not sure which one you mean so I’ll try to address both.

  1. If in the downgrade process, you opted to flag those packages as ignore, an update won’t be pulled when you update the system. You can change this ignore status by editing /etc/pacman.conf and removing it from the IgnorePkg section.
  2. Whether Nvidia will ever resolve this issue in the v555 (or newer) drivers for your generation of GPU is yet to be seen I’m afraid, but I wouldn’t give up hope just yet.

The first part I was aware of. The default in yay seems to be to not put it in IgnorePkg just yet and I followed that, but since it seems the issue in v555 will not be resolved too soon I will probably add it soon.
Thanks again for your help!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.