Screen not working properly

here we go again!
right so I have a 2k 165Hz screen on this laptop
inxi -Faz output
xrandr output
opening up the xfce display settings, i see that it’s on 60Hz. I have the option to go to 165Hz so i do…
“apply changes, keep changes.”
but it does not change. its still 60Hz. I tried changing it though xrandr, but that didnt seem to worth either.

thanks for any help in advance

:slight_smile:

XRandR shown by you looks slightly different. Mine looks like :

┬─[deweshk@HomeDesktop:~]─[09:20:42 AM IST]
╰─>$ xrandr
Screen 0: minimum 8 x 8, current 1360 x 768, maximum 32767 x 32767
DP1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
VGA1 connected primary 1360x768+0+0 (normal left inverted right x axis y axis) 410mm x 230mm
   1366x768      59.79 +
   1360x768      60.02* 
   1024x768      75.03    70.07    60.00  
   832x624       74.55  
   800x600       72.19    75.00    60.32    56.25  
   640x480       75.00    72.81    66.67    59.94  
   720x400       70.08  
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

Therefore, refresh rates according to screen size is not visible in your output.






I think you should use something like :

xrandr --output eDP1 --mode [your screen resolution] --rate [which you need]

But I am not much sure as I had thought of this according to your device’s XRandR.



Why not try to change with :

as expected, doing it with xrandr as you descried had no change.
The command did not fail. There was no error message. The screen DID flicker as if it was changing it’s refreshrate.
But it has not changed. Which makes it a very confusing issue to solve.
ill try that other program!

edit: looking into it, it uses xrandr - i think i’ll have the same result. furthermore it has a known bug with closed source nvidia drivers, and editing my xorg conf sounds very much like a recipe to screw things up. xorg is very much complicated to me still