Screen flickering in certain spots on Wayland with Nvidia card

New Linux user here. I’ve been told that Wayland is superior to X11 (which works fine for me), so I tried to switch. Now I have noticed my 2nd Monitor (which is connected to my Laptop via HDMI) flickering in what seems like the same spots every time showing my wallpaper. It gets really bad when having a game open or playing a youtube video. The flickering you are seeing here usually goes around my whole screen, but much less often.

fastfetch; System Info; nvidia-smi

Is there anything I can do about this or do i stay on X11? Would love to hear from you!

Chrome based browsers need to be told to use wayland, either set in flags or edit the desktop file exec line, e.g.

Exec=opera-beta --enable-features=UseOzonePlatform --ozone-platform=wayland %U

Flags are accessed via:


vivaldi as an example:

Do you use grub or systemd-boot?, is nvidia_drm.modeset=1 set?

Thank you for you answer!

I use LibreWolf, does it it automatically choose Wayland?

I use grub




Stick in /etc/environment and reboot.

I am downloading Doom Eternal to test (but it is a big download).

The only thing that noticeably changed in LibreWolf is that in flashes in a similar way Doom does. So i guess it uses Wayland now? :joy:

I appreciate you downloading the game just for helping me with my issue. I haven’t tried any other games on Wayland but I expect a similar behaviour.

Runs fine, I have a Legion5 AMD/RTX3070, but it runs hot with all the settings on medium. Am still on the 550 drivers, 555 was not working well, so I downgraded.

Chrome fixed the issue with wayland a few updates back I have mine set to
It works now with xorg and wayland

1 Like

There is some good stuff here:

and search for wayland here: