"Screen Energy Saving" Not Working

I had this problem before, but with the new KDE updates, it might have broken something.

I have it set to switch off my monitors after 20 minutes of inactivity. If I watch a movie and fall asleep, when the movie is done, it will turn off my screens after 20 minutes of it ending. But since 2 weeks ago, this isn’t happening.

As seen here. Is there some other location which is overpowering this? I used to have “suspend session” selected, too. And had problems, but after I unchecked that, it worked OK.

Any of you know anything about this?

I don’t know much about it so won’t be much help, but you could check your current DPMS settings with xset q then see if you can manually blank it with

xset dpms force off 	    (Turn off screen immediately)
xset dpms force standby 	(Standby screen)
xset dpms force suspend 	(Suspend screen)

More on DPMS can be found here:
If triggering it manually works, you’ll have at least narrowed it down to an issue with KDE and then you can start checking it’s logs and forums if no one else here has any ideas

** edit ** I’ve seen several older posts on the net saying kscreen has caused issues in the past so that could be something to explore as well

Says DPMS is disabled…

Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000002
  XKB indicators:
    00: Caps Lock:   off    01: Num Lock:    on     02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off
  auto repeat delay:  600    repeat rate:  25
  auto repeating keys:  00ffffffdffffbbf
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  2/1    threshold:  4
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  600
  default colormap:  0x20    BlackPixel:  0x0    WhitePixel:  0xffffff
Font Path:
DPMS (Display Power Management Signaling):
  Standby: 0    Suspend: 0    Off: 0
  DPMS is Disabled

What happens when you try to turn it on?
xset +dpms
Here’s good info on xset: https://twiserandom.com/unix/xset-a-tutorial/index.html

Sorry, been busy the last few days.

xset +dpms

It did turn DPMS on, but it’s still not doing anything to the system/screen.

When you turn it on does it change this to something other than zero?:
Standby: 0 Suspend: 0 Off: 0

Yeah, it’s still showing me

DPMS (Display Power Management Signaling):
  Standby: 0    Suspend: 0    Off: 0
  DPMS is Enabled
  Monitor is On

Did you try setting your timeouts?
xset dpms 900 1200 1500 or whatever?

I tried setting 600 to standby, but it doesn’t do anything…

Why try only one mode? I’m not sure what the difference is between standby, suspend, and off when it comes to display power mangement and how they’re all activated. I’d try setting all three. Also, it looks like you don’t have a timeout for any blanking either. Set that with xset s 300 or whatever.

If that doesn’t work maybe someone else can help. It’s possible whatever KDE is using is overriding xset and I’m not too familiar with KDE power management.

Umm, guys, my monitors go on standby now, after 20 minutes. Might be a KDE bug that they fixed…