Screen capture problems

Hello, I have a laptop with an Intel processor and integrated graphics. For some time now I have had issues with Spectacle showing old screen, I am always able to fix it only momentarily by switching Keep window thumbnails. Recently I also found out that I have a similar issue when streaming through discord and eventually the stream even crashes. I was able to find one other solution online, uninstalling some intel drivers but that seemed a bit unsafe for me.
I am very grateful for any suggestions

This has been happening to me from quite some time now on kde. Here are some things you can try:

  • SystemSettings > Compositor > Vsync: off
  • Remove the package xf86-video-intel
  • This doesn’t happen on wayland
  • Make sure you are using “OpenGL 3.1”

All those don’t work for me though, so I simply restart the compositor which fixes the issue. I have made an alias for that long command:

alias restart-compositor='qdbus org.kde.KWin /Compositor suspend && qdbus org.kde.KWin /Compositor resume'
1 Like

I did not try the Vsync one yet so I’ll give that one a go. At the same time, I also did not try removing xf86-video-intel is it really safe ?

Worth a try. In case you get a black screen after reboot then try switching to tty (if not able to do that then you can chroot) and install it back to fix. Both ArchWiki and KDE recommend not using it…atleast on newer GPUs.

The last few times this came up which is easily searchable on the forum this was the solution.

1 Like

okay thanks, I will give it a try then

Alt+Shift+F12 should toggle compositing (X11 only).

IIRC, removing xf86-video-intel solved the problem for me

That is helpful, but I don’t find it in KDE docs. Where can I find a complete list of keyboard shortcuts?
I just switched to KDE Plasma last week.


It does work, doesn’t it?

KDE’s documentation is a bit of a rabbit’s warren and the devs do move things around sometimes.

You should have ~/.config/kglobalshortcutsrc. Search that for “suspend”.

If I find any decent documentation on the shortcut, I’ll let you know.

Edit: you could also look under System Settings > Shortcuts. What I’m posting next could possibly be outdated / moved around / named differently but, under Shortcuts > Global > there’s a KWin component and in the right pane there are a lot of keyboard shortcuts with their default settings and a GUI to add your own for the particular function.

There might be an entry for “Suspend Compositing” with the shortcut I mentioned.

Yes, it works!

I’m a new KDE user, So you know this off the top of you head or have you made a list of useful shortcuts?


There are too many shortcuts to keep in mind, so yes, a list of shortcuts is needed and it will differ from user to user depending on the usage pattern.

Anyway, I was quite an active user of KDE Plasma but now I’m transitioning to Sway: more peaceful :wink:


Hopefully someone has compiled a general list.

Looks like removing xf86-video-intel solved it for me, or at least I did not encounter it for a day now, thanks

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.