Screen Capture issue (OBS, Peek, Simple Screen Recorder or other screen capture tool)

Hi! I recently encounter an issue inside endeavourOS or maybe is just in my machine. The probem is that whenever I star to record my screen with OBS or Simple Screen Recorded the output is tearing like crazy. I try to fix this out but I just break my plasma desktop.

I tried to enable the “tearfree” option in the /etc/X11/xorg.conf.d/20-intel.conf file like so:

Section "Device"
	Identifier "Intel Graphics"
	Driver "Intel"
	Option "AccelMethod" "sna"
	Option "TearFree" "True"

Also I tried to change the option “sna” to “uxa” but it didn’t help. Even I tried to disabled virtual synchronization creating a file ~.drirc

<device screen="0" driver="dri2">
	<application name="Default">
		<option name="vblank_mode" value="0"/>

Here are my specs. Thanks in advance to anyoine who can help with this.

inxi -F
  Host: endeavour Kernel: 5.14.16-arch1-1 x86_64 bits: 64
  Desktop: KDE Plasma 5.23.2 Distro: EndeavourOS
  Type: Laptop System: TOSHIBA product: Satellite U940
  v: PSU6SP-01CLM1 serial: <superuser required>
  Mobo: TOSHIBA model: VCUAA v: 1.00
  serial: <superuser required> UEFI: TOSHIBA v: 1.20
  date: 09/19/2012
  ID-1: BAT1 charge: 9.8 Wh (100.0%)
  condition: 9.8/32.6 Wh (30.2%)
  Info: Dual Core model: Intel Core i5-3317U bits: 64
  type: MT MCP cache: L2: 3 MiB
  Speed: 798 MHz min/max: 800/2600 MHz Core speeds (MHz):
  1: 798 2: 1080 3: 1028 4: 857
  Device-1: Intel 3rd Gen Core processor Graphics
  driver: i915 v: kernel
  Device-2: Chicony TOSHIBA Web Camera - HD type: USB
  driver: uvcvideo
  Display: x11 server: 1.20.13 driver: loaded: intel
  unloaded: fbdev,modesetting,vesa
  resolution: <missing: xdpyinfo>
  Message: Unable to show advanced data. Required tool
  glxinfo missing.
  Device-1: Intel 7 Series/C216 Family High Definition Audio
  driver: snd_hda_intel
  Sound Server-1: ALSA v: k5.14.16-arch1-1 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: yes
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet
  driver: N/A
  Device-2: Intel Centrino Wireless-N 2200 driver: iwlwifi
  IF: wlan0 state: up mac: 9c:4e:36:81:87:cc
  Device-1: Integrated System Solution Bluetooth Device
  type: USB driver: btusb
  Report: rfkill ID: hci0 state: up address: see --recommends
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode]
  driver: ahci
  Local Storage: total: 495.58 GiB used: 234.91 GiB (47.4%)
  ID-1: /dev/sda vendor: Toshiba model: MQ01ABF050
  size: 465.76 GiB
  ID-2: /dev/sdb vendor: Samsung model: MZMPC032HBCD-00000
  size: 29.82 GiB
  ID-1: / size: 28.68 GiB used: 20.81 GiB (72.5%) fs: ext4
  dev: /dev/sdb2
  ID-2: /boot/efi size: 511 MiB used: 296 KiB (0.1%) fs: vfat
  dev: /dev/sdb1
  Alert: No swap data was found.
  System Temperatures: cpu: 50.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 230 Uptime: 30m Memory: 7.66 GiB
  used: 2.42 GiB (31.6%) Shell: fish inxi: 3.3.07

Remove xf86-video-intel and try the built in modesetting driver.

Thanks for your help. So I just need to uninstall with pacman sudo pacman -R xf86-video-intel? And then, how can I install and configure the modessetting driver?

That will do it, shouldn’t need any config, but:

Has all the details.

Thanks a lot. I will read and tried that :smiley:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.