Screen brightness nvidia 390xx

I have some issue after installing endeavour 22.12. Backlight adjustment of the screen doesn’t work at all.
I have laptop DELL M6600 with nvidia 3000M GPU and KDE as DE. Buttons to change brightness on keyboard doesn’t work.

ls /sys/class/backlight/ shows nothing.
previously I used vanilla ARCH instaled by CALAM-arch live iso. Backlight used to work like a harm. Now after reinstalation and changing to endeavour it doesn’t work. I have keyboard backlight working but no screen.

Where should i look and what to change to force system to work properly?

Welcome to the forum! :smile:

xrandr has some options for adjusting the screen brightness.
Worth checking.

There are also a few packages that help, so you can search e.g. with command

yay -Ss screen brightness

or with some other search words.

1 Like

I’ve tried light and xorg-xbacklight and kernel parameter acpi_backlight=video and …=none but with no luck. Even I’ve changed kernel from linux to linux-lts.
During endeavour instalation i had optimus swiched on but later i swiched off and now i have only nvidia GPU on. Maybe I should reinstall system?

Problem solved (partially). I just reinstalled clean arch and backlight works on nouveau with latest kernel or with proprietary nvidia driver and lts kernel. Vanilla arch is much faster on my laptop too than endeavour os.
Backlight won’t work on nouveau nor proprietary driver regardless kernel on endeavour os. So first attempt to system is a totally fail. I doesn’t install from live cd without additional effort and basic knowledge. Calamare installation program had problem with pacstrap. I had to update archlinux-keyring and live cd by pacman -Syu. And after that i could install system to my disk. So in my opinion Endeavour Os is not an Arch for beginners.

Sounds like the Arch mirrors are not optimal for your location for the EndeavourOS install.
Use e.g. reflector or rate-mirrors to update them before actual install.
Updating archlinux-keyring or pacman -Syu on the live user should not be needed.

I agree it shouldn’t be need but unfortunately it was. I prepared live usb by ventoy. I started installation and at the beginning calamare just stopped working and closed. Next time i did update keyring and calamare broke again. At last I updated keyring and live iso and installation was successfull.

I used mirror generator from arch website to get mirrorlist.

Could you show any logs about the problems?
That would help a lot.

I’m really sorry but I don’t have any. I’ve got error during installation process about pacstrap. First calamare removed all mirrors :smiley: so pacstrap just died. It has script to find fastest mirrors so calamare tried use rankmirror but it removed all mirrors instead of getting fastest one. Next time I copied mirrors from arch mirror generator but without updating keyring pacstrap couldn’t get valid pgp keys so it broke again.

Did you look at this:

I’d not use ventoy. The best is dd for creating the USB installer.

I used ventoy with uefi boot. Endeavour was the latest version 22_12 and it worked very well as live usb system but it made problems during instalation like a mention above.

Without logs it is unfortunately impossible to find the reason for this.