Screen bleeding and bad text rendering

I have two problemes with my screen, which are maybe linked :

  • The first is screen bleeding around some text, and I see red, green and blue spots on the sides of the letters :

  • And the second is text look “broken” on gtk4 apps :

I booted on a live USB of Pop!_OS to check if it was the screen itself, but everything was perfect on this distro, so I think it is a software probleme.

I’m running EndeavourOS i3wm on a 2015 macbook air.

Here’s the output of inxi -Faz :

  Kernel: 5.15.77-1-lts arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
    root=UUID=962a6274-b509-42f7-a300-02cfe347aa90 rw rootflags=subvol=@
    resume=UUID=9cc8185c-c84b-41d5-91d1-313fc6d455f5 loglevel=3 nowatchdog
  Desktop: i3 v: 4.21.1 info: polybar vt: 7 dm: LightDM v: 1.32.0
    Distro: EndeavourOS base: Arch Linux
  Type: Laptop System: Apple product: MacBookAir7,2 v: 1.0
    serial: <superuser required> Chassis: type: 9 v: Mac-937CB26E2E02BB01
    serial: <superuser required>
  Mobo: Apple model: Mac-937CB26E2E02BB01 v: MacBookAir7,2
    serial: <superuser required> UEFI: Apple v: 427. date: 06/13/2021
  ID-1: BAT0 charge: 48.9 Wh (100.0%) condition: 48.9/53.2 Wh (91.9%)
    volts: 8.2 min: 7.6 model: SMP bq20z451 type: Li-ion serial: N/A
    status: full cycles: 111
  Info: model: Intel Core i5-5250U bits: 64 type: MT MCP arch: Broadwell
    gen: core 5 level: v3 note: check built: 2015-18 process: Intel 14nm
    family: 6 model-id: 0x3D (61) stepping: 4 microcode: 0x2F
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 1907 high: 1967 min/max: 500/2700 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 1792 2: 1955 3: 1915
    4: 1967 bogomips: 12800
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel HD Graphics 6000 vendor: Apple driver: i915 v: kernel
    arch: Gen-8 process: Intel 14nm built: 2014-15 ports: active: eDP-1
    empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:1626
    class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 compositor: Picom v: git-7e568
    driver: X: loaded: intel unloaded: modesetting alternate: fbdev,vesa
    dri: i965 gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1440x900 s-dpi: 96 s-size: 381x238mm (15.00x9.37")
    s-diag: 449mm (17.69")
  Monitor-1: eDP-1 mapped: eDP1 model: Apple Color LCD built: 2012
    res: 1440x900 hz: 60 dpi: 126 gamma: 1.2 size: 290x180mm (11.42x7.09")
    diag: 341mm (13.4") ratio: 16:10, 15:9 modes: 1440x900
  API: OpenGL v: 4.6 Mesa 22.2.3 renderer: Mesa Intel HD Graphics 6000 (BDW
    GT3) direct render: Yes
  Device-1: Intel Broadwell-U Audio vendor: Apple driver: snd_hda_intel
    v: kernel bus-ID: 00:03.0 chip-ID: 8086:160c class-ID: 0403
  Device-2: Intel Wildcat Point-LP High Definition Audio
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9ca0
    class-ID: 0403
  Device-3: Broadcom 720p FaceTime HD Camera driver: N/A pcie: gen: 2
    speed: 5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 14e4:1570 class-ID: 0480
  Sound API: ALSA v: k5.15.77-1-lts running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.59 running: yes
  Device-1: Broadcom BCM4360 802.11ac Wireless Network Adapter vendor: Apple
    driver: wl v: kernel modules: bcma pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    bus-ID: 03:00.0 chip-ID: 14e4:43a0 class-ID: 0280
  Device-1: Apple Bluetooth USB Host Controller type: USB driver: btusb v: 0.8
    bus-ID: 1-3.3:6 chip-ID: 05ac:828f class-ID: fe01
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Local Storage: total: 233.76 GiB used: 151.64 GiB (64.9%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Apple model: SSD SM0256G
    size: 233.76 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: EA0Q scheme: GPT
  ID-1: / raw-size: 224.66 GiB size: 224.66 GiB (100.00%)
    used: 151.04 GiB (67.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 608 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 224.66 GiB size: 224.66 GiB (100.00%)
    used: 151.04 GiB (67.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-4: /var/log raw-size: 224.66 GiB size: 224.66 GiB (100.00%)
    used: 151.04 GiB (67.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8.8 GiB used: 615.8 MiB (6.8%)
    priority: -2 dev: /dev/sda3 maj-min: 8:3
  System Temperatures: cpu: 65.0 C pch: 58.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 242 Uptime: 2h 43m wakeups: 5 Memory: 7.67 GiB
  used: 2.72 GiB (35.5%) Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: 1430
  pm: pacman pkgs: 1424 libs: 304 tools: trizen,yay pm: flatpak pkgs: 6
  Shell: Bash v: 5.1.16 running-in: xfce4-terminal inxi: 3.3.23

Thank you for your answers.

Hey, first of all try that and report back:

Thank you. I tried but it doesn’t works.

you’re an avid i3 user, is there anything else specific to it?

Does it happen under some specific circumstances / programs?
Like for example only GTK programs, or only qt…or is it system-wide everywhere?

The screen bleeding is system-wide everywhere, and the bad text rendering is only on GTK apps, and especially libadwaita apps.

Which application is this?

It is on my full system.

Looking fine here. (Slightly outdated) Arch + i3 + same model Mac

Wich kernel are you using ? (I personnally use the LTS one because the wifi doesn’t work with the normal one).

I use “normal” kernel because LTS doesn’t pick up my USB HDD and therefore cannot boot :sweat_smile:
WiFi works here, though. (with wl)

I3 default setup only sets theming, but nothing related to font rendering… i have issues only aside from some fonts looking bad on i3 in general .

But noto sourcecode pro or jetbains mono are looking very sharp here…

Font rendering is highly related to GPU and display .
So could be some font setting can solve such issues


Yeah, i guess that’s what i was asking…Not sure what else except fontconfig in i3 could.


I wonder, have you tried just for a test booting from :enos: liveiso and see if it’s XFCE looks fine for you?

Fact is that big DEs have options for brg RGB e.t.c and dpi settings . On i3 you need to set with x tools or such…

Just find a funny article:

1 Like

Indeed, usually a good place to start for most systems would be:

Anti-Aliasing Enable
Sub-pixel rendering RGB
Hinting Slight

Here’s something to note about sub-pixel rendering, which might cause that issue if monitor is not RGB. but BGR


P.S. thx btw, i had no idea how to set some of those with fontconfig…coz mostly i sit in KDE which does all that :sweat_smile:

and archlinux has cleartype enabled by default as far as i rememebr could be also an issue on mac displays :wink: ?

only to joke around one last time here:

while me looking at the picture:


Additionally, there’s also ways to enable Microsoft’s Cleartype subpixel rendering by recompiling Freetype (disabled by default because of patent), and ways to tweak the subpixel rendering matrix by manually editing the Freetype code. But why go through the hassle.

Definitely not :wink:

It should have that instead:


they join oin a long time ago…

and yes cleartype is enabled by default as of the archwiki atleast:

1 Like

Oh my…Time moves way too fast!


here are some other places to look: