Scan Wi-Fi Networks

This is my first time using the Endevour OS i3WM variant, but not my first time with i3. How do I scan for Wi-Fi networks? I’ve used the D-menu(rofi) and all I seem to see is advanced network configuration which prompts me to enter everything like SSID and etc. Do I need to install an additional package for that or it’s already there under a specific name.

Make sure that

#exec --no-startup-id nm-applet

is uncommented in your i3 config file:

# networkmanager-applet

exec --no-startup-id nm-applet

Reload i3.


Normally when I install i3 WiFi just works. Isn’t nm normally set on install to work? :thinking:

Wi-Fi works, I just don’t know where to scan networks. It connected to my home network just fine when I installed it, but I am trying to figure out how I can scan the networks to connect to a different one.

Seems not:

You need to run nm-applet. Looks like it is not “on” by deafult in EnOS’ i3 config.
From nm-applet on your bar, you could see and connect to other networks.
See my previous post.

Ive never had an issue . It sees the networks. :man_shrugging:

Edit: Unless somethings changed as i haven’t installed it in a while.

thank you @pebcak that worked! I’m gonna ave to work on some theming because even with the dark theme all these pop-up menus are white :sweat_smile:

1 Like

if you real get into WM’s + move away from "point + click "

you might be interested in
" "

nmcli or nmtui . Hope you enjoy your Xp on EOS i3 ( it well put together )

EndeavourOS default setup uses dex what will start nm-applet on logins automatically it should show up on bottom right panel in tray … where you can access by right/left clicking the icon… if dex is not installed you would need to uncomment the nm-applet starter in config…

Shouldn’t the first exec line be uncommented then also?

# dex execute .desktop files + apps using /etc/xdg/autostart.
# when second to i3 a DE is installed or mixed usage of i3 + xfce4 or GNOME
# in this cases better disable dex and use manual starting apps using xdg/autostart
# if enabled you should comment welcome app.
#exec --no-startup-id dex -a -s /etc/xdg/autostart/:~/.config/autostart/
exec --no-startup-id dex --autostart --environment i3

no that’s only alternative the i3 variant is working best for i3 :wink:
I do use this for years day in day out…

1 Like

1 Like

I’ve commented out the nm-applet and I still see networks and it’s themed properly. I assumed that is dex?

Must be it … so it does work properly now?

1 Like

Yup all good!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.