Scaling issue on BSPWM

Well my problem. Is the complete opposite. I downloaded the newest eos release with bspwm on my surface pro6. Everything is so tiny I need a magnifier to see everything. Now when I flasg cinnamon for example, it’s normal size… Any thoughts?

Bspwm is a community edition and i don’t use it much but i do know what you say. I have the same issue on my hidpi HD display on i3 and bspwm too. You can adjust the fonts larger is all i know. I haven’t spent much time with those desktops. I use mostly KDE, Xfce and Cinnamon.

1 Like

OK that’s what I have been doing as well… Just weird that other DE don’t do that. I can barely read the status bar at the top lol… Thank you kindly for the reply though

Perhaps @OdiousImp or @Elloquin @ringo can shed a light on this issue? (They are the ones behind our BSPWM spin.)

1 Like

I have created a new thread of your issue, to make it more clear. :wink:

Got it thank you

1 Like

Rick is correct though, I’ve attempted i3 and bsp and they both have desktops that are so small… Every other DE is normal desktop size given obviously what a person is using.

PixelSense-Display (12,3 Zoll)
2736 x 1824 (267 PPI)

Has a lot of pixels…

Both has no DE alike automatic detection for displays and will need to set them up manually using arandr p.e. … in Terminal you can increase the size by pressing [ Ctrl +++ ] which could help you to use xrandr from command line… If you are able to set display size with arandr gui you only need to save the settings as monitor in the folder it defaults too (~/.screenlayout/monitor ) i3 config will use this on next login automatically.

Could also be needed to configure scaling (aka hdpi)

You could add “dpi: 117” to .Xresources. If that is still too small increase the setting to, say, 140. BTW after editing .Xresources, you should run the command $ xrdb .Xresources.

4 Likes

What @davidw posted should work.

Adding to that, here’s an Arch Wiki link

https://wiki.archlinux.org/title/HiDPI#X_Resources

Problem is that full DE will be able to set scaling, but WM don’t have any features for that.

2 Likes

Thank you guys will try it out

“Thank you guy will try it out” is not a solution! Mark the post that solves your issue as the solution!

1 Like

@Sev7en
Try out and actually work . That two different thing .

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.