Saving battery time with Powertop

I have installed powertop to save me some battery time.
I have followed this arch how to “powertop arch”.
I have initiated a calibration # powertop --calibrate to create an auto tune base for the systemd service.
I have started and enabled the systemd service. Then rebooted. I am finding that the service won’t start.
Strangely enough I have
Active: inactive (dead) since Tue 2020-12-08 12:37:17 CET; 1min 3s ago
and then
saturne systemd[1]: powertop.service: Succeeded.

Is it dead or is it alive and running as one would expect ?

According to the log, it Succeeded and Finished.

Thanks for your time.
Why is it saying " Active: inactive (dead) since Tue 2020-12-08 12:37:17 CET; 1min 3s ago" ?
As another ex, thermald is showing active and running

Added “RemainAfterExit=yes” in the service tab and it seems to have made a difference on the state where its now showing the service as active but exited. Still somewhat confusing :slight_smile:

The powertop service runs powertop once at boot, it doesn’t stay active in the background.

Yes - you’ve told the service to remain active after the program has exited.

1 Like

Ok thanks for the help

Interesting… I was just tuning up my new Elitebook 845 G7 (Ryzen 4750U) and followed this excellent article regarding disabling unneeded hardware in BIOS, and running powertop:

I had no idea latte-dock was such a little pig… LOL… removed it and now just use a simple KDE panel with Quick Launcher widget instead.

1 Like
fwiw

It is possible to post the terminal output as text. Just copy, paste, higlight and use </> button to format. This will make them easier to read, to copy and their contents will be searchable by engines.

2 Likes

Out of the box, powertop showed all of default EndeavourOS settings to be “good” except for one, VM writeback timeout:

>> Bad           VM writeback timeout                                                                                   
   Good          Wireless Power Saving for interface wlan0
   Good          NMI watchdog should be turned off
   Good          Enable Audio codec power management
   Good          Bluetooth device interface status
   Good          Runtime PM for I2C Adapter i2c-5 (AMDGPU DM i2c hw bus 2)
   Good          Runtime PM for I2C Adapter i2c-6 (AMDGPU DM i2c hw bus 3)

When I check

cat /proc/sys/vm/dirty_writeback_centisecs

It shows 6000… 60 seconds correct? I think powertop suggests 1500, 15 seconds?

1 Like

Yes, looks like so. After tuning I get:

cat /proc/sys/vm/dirty_writeback_centisecs
1500

@darkhorse
did you switch to lz4 compression ? If yes, do you see any change ?

I did not fiddle around with compression… it looks like EndeavourOS uses TLP… so I’m not running powertop as a service since the tlp.service is already active by default.

As for vm writebacks… these are controlled by the /etc/tlp.conf file, I’m just going to keep the defaults:

# Dirty page values (timeouts in secs).
# Default: 15 (AC), 60 (BAT)

#MAX_LOST_WORK_SECS_ON_AC=15
#MAX_LOST_WORK_SECS_ON_BAT=60

1 Like