Same Cable Different Internet Speed on Different Machines


there is this recurring poblem with internet speed on my main machine.
After a few days, maybe more, the internet speed drops from 1Gbps to 80Mbps/s.
At first, I thought it was my ISP limiting my speed.
But when I test the same cable on a laptop, I get 1Gbps/s.

Without doing anything, the speed on my main machine comes back after few hours, sometimes days.

I tried powering off the modem and restarting it after few minutes. But it doesn’t work.

I tried different port on the modem with different ethernet cables but I get the same results.
The main machine gets stuck at 80Mbps for a few hours or days, whereas on the laptop the internet speed is normal.

I’m not sure where to start or where to look at.
On the main machine (desktop) there is endeavourOS i3 and on the laptop there is Manjaro i3.

Any ideas on what to troubleshoot?

I’d start with the journal logs. If you’re using NetworkManager,

$ journalctl -u NetworkManager | eos-sendlog

It is also possible that there’s an issue with the network interface of your main machine. You can also test the network of your main machine with different kernels.

1 Like

I assume the auto-negotiation of speed is seeing something it does not like and down-grades the interface. You can typically go into your network manager settings, find the “Link negotiation” settings, and change the mode to “Manual” and then select a speed with the NIC should handle. Worst case is that it works worse, but, in my case, it keeps the link speed up (at 1Gb/s) and keeps working just fine. Per my experience, the link speed negotiation algorithms are sometimes lame or too conservative.

1 Like

I’ll try that.
The link negotiation was on “Ingore”.
But it usually works fine.
Now it’s on manual, 1Gb/s and Duplex full.

So I think I need to know more about how you are testing speed before you look at hardware. Things you want to consider:

  • Different Ethernet and wireless cards perform differently between hardware.
  • The Firmware can play into the inconsistency.
  • And yes throttling and all kinds of internet shananigans.

Can you describe how you are testing speed?

My suggestion:

Use the website:

Then try this:

  1. Stay on the same computer.

  2. Boot into the Endeavour LIVE USB and then run a speedtest.

  • Capture a screen shot of the results.
  1. Boot into regular Endeavour OS and run the speed test and see if they differ.
  • Capture a screen shot of the results.

I do get your speed is fluctuating. But you must stay on the same hardware. If the machine has Windows dual booted … run a test there too.

Also so we know your hardware … run this command from terminal:

inxi -b
1 Like

Sorry for the late answer.
Since it happens randomly, I haven’t been able to re-create the problem.

I always use to test my internet speed.
Next time I’ll try cloudflare’s tool.

When the problem happened, I tested the internet speed with endeavourOS and since I have dual boot with windows 10, I tested under windows 10 on the same machine/ethernet chip but the problem was the same.

Which leads me to think, maybe it has something to do with my cable modem, maybe flagging my machine’s local network IP. is that possible?

Internet providers usually over sell their service and usually don’t have the bandwidth to give you consistent speed. So in my town after 6 pm was peak usage in the neighbourhood and internet would drop to 25% of the normsl speed till 9 pm during the work week.

So if i’m testing network speeds to see if there is a hardware problem i take the internet out of the equation. Copying files over the network between computers is a better benchmark.

There are many traffic shaping technologies, load balancing, and other sneaky stuff. I’m sure you already read about that.

1 Like

I have experienced this too at some point. The Ethernet protocol has a graceful degradation mechanism built in. If the cable or connector has some issues, instead of not working, the protocol is downgraded to what the connected wires allow. so let’s say there is an imperfect contact and only 6 out of 8 wires are connected, the protocol is downgraded to 100mbit, instead of downright not working. I had a loose connector that sometimes worked sometimes not, arbitrarily. I would start the debugging at this point if I were you. Before going in to deep in software troubleshooting.


What is your ethernet chip btw?

inxi -Na