Samba share not working after update 28/03/22

I found the update which is causeing the fault (smbclient 4.16.0-2) if I downgrade to smbclient 4.15.5-1 the samba share works just fine.

The error message I get is [Unable to mount location and Failed to mount windows share: invalid argument]

The samba share is used to admin my NAS which is Raspberry PI4 running four sata hdd’s


Have a look at this and see if it relates to your issue:

And welcome to EnOS’ forum!

Thanks, I’m getting this error as well when I try to access folders on my Qnap NAS

Thanks for the reply, but I do not use Nautilus so that not the problem.
All file managers show the same problem.


1 Like

There is an update:
smbclient 4.16.0-2 -> 4.16.0-3
Hopefully the issue is resolved uppstreams.

Maybe this is only affecting NAS connections. My (4) test VMs (Arch-based and Windows 10) are not having any issues.

It has been fixed with 4.16.0-4, samba and smbclient by reverting this commit:

I still have the same problem with 4.16.0-4. A few m8 have the same problem.

I was having an issue with this last night. Same error

Failed to mount windows share: invalid argument

I solved it by accessing it via the Pi’s hostname instead of IP, which required me to re-enter the password for the share. (smb://pi@HOSTNAME/share)

Possibly could fix it by deleting the stored password and re-authenticating too.

All fixed how. Some of it was my error as I had screwed with so many settings.

I’ve still got the issue although I cleared out and re-entered my password… I’ll try using IP address later on.

Edit: IP address still gives me the same error

ok, i can make it work if I put my username and password in the SMB URL. Is there a more permanent solution on the way? I had cleared out my saved password before but that didn’t solve it, nor swapping to an IP address

Check out this video its for Ubuntu but works just fine on most arch based system

gvfs updates finally solved it for me

1 Like