Samba Server Configuaration window unreadable on HiDPI

Hi all
I would like to use system-config-samba as per the suggestion on this EOS wiki. I have EOS Xfce installed on a HiDPI laptop and have not encountered any problems with the readability after changing the configuration:
Xfce Settings Manager > Appearance > Settings > Window Scaling 2x &
Xfce Settings Manager > Window Manager > Style* select Default-xhdpi theme
The Samba Server Configuration window however is tiny/unreadable on my configuration.
I am confused about toolkits/window managers/Xsevers etc. and cannot seem to find out how to make this window readable.
Any help is appreciated.

? can you show it?


this do not appear immediately

yes exactly if there are two reply buttons one directly under a post of a user and a main one to reply to the topic, if you reply to my post i got a notification…

this looks like xfce4 DE? and system-config-samba or smb4k ??

Xfce4 DE and system-config-samba

GTK 2 issue maybe as xfce4 now is on gtk3 and scs is using pygtk what is (afaik) GTK 2 …
so settings from xfce4 are not working for it… .

1 Like

may this is working:

yay -S run_scaled-git
run_scaled --scale=2 --opengl=auto --sleep=1 system-config-samba

Now I understand better. Thanks!

Wil try that

or try Smb4K

this is qt (KDE-Plasma) but may be working good under xfce4…

A possibility occurs to me here - but no knowledge. I haven’t used Samba in a while (since it was updated a while ago and stopped working with Android File managers). However - could that editing of system-config-samba be taking place under root access (sudo?). If so, the HiDPI settings aren’t used on the root account without some effort. Perhaps logging in as root graphically, and resetting those scaling values?

Hopefully someone knowledgable will comment before anyone tries this!
(fully prepared to pull this comment…)

Freebird54

not that wrong here … if system-config-samba runs as root… so you need to setup root settings to hidpi also…


su
xfconf-query -c xsettings -p /Gdk/WindowScalingFactor -s 2
1 Like

Okay, removed package system-config-samba (did not get ‘run-scaled’ to work) and replaced with smb4k.
After export of QT_SCALE_FACTOR=2 this gui is fine.
Thanks!

2 Likes