Samba client issues

Hi all, I have a new install with brand-new hardware. When trying to connect to a samba server from nautilus by clicking on the computer under “Network” it fails with an error saying it fails to get the list. If I try to connect with smb:/// sometimes it connects correctly, but mostly it does not connect. I can easily connect with smbclient. I also have other computers which connect without issue so I can only assume I have something wrong on my new desktop. Any suggestions how to trouble shoot this?

packets must be downgraded

@JR29 not sure I understand what that means, can you please elaborate

gvfs-smb: ignoring package upgrade (1.44.1-1 => 1.44.1-4)
-> ldb: ignoring package upgrade (1:1.5.6-2 => 1:2.1.4-1)
-> ignoring package replacement (libwbclient-4.10.10-2 => smbclient-4.12.6-1)
-> samba: ignoring package upgrade (4.10.5-1 => 4.12.6-1)
-> smbclient: ignoring package upgrade (4.10.10-2 => 4.12.6-1)

@JR29 OH ok so you’re saying I need to down grade those packages. I’ll give that a try.

The odd thing, I just checked my laptop, which is working and I have the most updated versions

installed downgrade, it is in our warehouse

I tried to downgrade the suggested packages and I was going to be messing because of gnome conflicts so I’ve not tried that yet. That said, I added

server min protocol NT1

to my smb.conf and at least now I can connect from nautilus. Still trying to figure out what is different between the computer that works and the new build.