Ryzen 3200u OpenGL Issue

I have an Asus Vivobook with a Ryzen 3200u processor and Vega graphics. I’ve had some issues with stability and OpenGL I could use some help on.

When I bought the laptop, I purchased an additional 8gb memory stick and installed it for a total of 12gb. The laptop however had a periodic hard freeze issue. I tried updating the bios to the latest version (I think it’s April 2020) but that did not solve the issue. I pulled the memory out and that did seem to make it better but now we are stuck with 4gb. That being said, it runs stable and fine for most of what my daughter needs to do anyway.

Memory issue aside, my daughter wants to play some Team Fortress2 from my Steam account. I installed Steam and the game and launched it. There appears to be a problem with OpenGL however. Difficult to describe but the screenshot shows it well.

We can’t even get the game to start, it just sort of freezes in the menus. We can kill the game and return back to the desktop. I believe this is happening to all of the games that require OpenGL but I could not say for certain. GLGears will run without issue but a benchmark like unigine-heaven has all sorts of screen corruption and horrible framerates.

Now, I’ve used Linux for almost 20 years but I will profess, when it comes to troubleshooting graphics issues, I’m at a complete loss. I believe I am using the AMDGPU driver but I have no idea how to change drivers if I wanted. Sorry for my total noob status in this arena. Any assistance to troubleshoot would be greatly appreciated.

Forgot to add… I am running all of the latest updates for Arch as of today.
Kernel version is 5.6.14.
X.org 1.20.8
DRM 3.36.0

Hello @adamis
So it looks like you have KDE Plasma installed. When you had the memory installed did you do any memory tests for errors after seeming to have issues? Not sure if the larger memory module needs to be in the first slot without checking the specs in the manual. Some boards are finicky.

If you have inxi installed you could post at least some hardware info.

inxi -FGz

It should be using the AMDGPU kernel drivers i think. As you say it’s up to date so i can only suggest looking at the compositor settings for the screen issue. They are in system settings, display & monitor?

I think this laptop has AMD RX 540X?

It’s been a while but now that you mention it, when I was first running KDE, I actually had to disable the compositor because of issues I was having with it.

I did find out that with the Ryzen processor, you can install a microcode package from Arch. I am tempted to reinstall the 8gb of Ram and see if the microcode update will make it run more stable. If I had the option, I would remove the 4gb and just replace with the 8gb but the 4gb is on the side of the motherboard that is inaccessible without taking the entire laptop apart.

Ya . a lot of new motherboards on certain laptops have soldered memory also on the first 4 GB. It is using the AMDGPU kernel module and amd-ucode should be installed. You can check that.

pacman -Q amd-ucode

Edit: There is a setting in compositor for screen tearing? It would be nice if you could get the memory working as 4 GB isn’t that much running KDE.

Here’s what I have (AMD integrated graphics):
in /etc/X11/xorg.conf.d, place a file 20-amd.conf with the following contents:

Section "Device"
	Identifier  "AMD"
	Driver "amdgpu"
    Option "TearFree" "on"
EndSection

and see if it helps. BTW - the microcode (amd-ucode.img) is definitely in use on my system. It should be loaded by grub, or rEFInd or however you boot.

I don’t have any tear problems with may AMD. Just the issue with Deepin freezing with Windows Effects off which really doesn’t even make any sense. But i have it working so that’s all that matters.

Yeah - but my screen went nuts when xfce came out with 4.14. I don’t know that I would have called it tearing, but it appeared to be trying to show uninitialized video memory or some such!
It could be ‘fixed’ by changing xfwm4 vblank to xpresent OR, eventually, by the entry shown above, which appears to be more comprehensive.

Mine was the same as i have two other older Radeon HD computers. It’s the vblank setting…i just turn it off.

I put the 8gb of RAM back in, we shall see if the AMD-UCODE makes it run more stable. So far it seems to be working well enough. The ucode is amd-ucode 20200421.78c0348-1.

Back to the original problem. I did try creating a 20-amd.conf file with those contents two nights ago (while initially trouble shooting). When I rebooted, SSDM would not connect to any displays. It would just boot me to a console. I had to delete the file to get SDDM to work again.

Did a quick run of the unigine-heaven benchmark. This is what I get. With just the 4gb of Ram it would loop without an issue. With the extra 8gb, it froze after a seconds. That being sad, the Ram isn’t my concern, it is the video issues that I need to figure out.

Not sure if this also helps but just tried ExtremeTuxRacer. Graphics were perfect and fluid. If I recall correctly, this should be an OpenGL game.

Last screenshot for the night… I managed to get a practice session of Team Fortress 2 to start. Graphics are very smooth but same coloring issue and texture issue is occuring as the pre-game menus.

Any suggestions on how to tackle this issue?

I’m afraid that my knowledge of the issue is limited, and probably exceeded by your own. Which driver did you end up using so far? That might spark a memory of something I’ve run across out there…

This is a thread which I am following with problems with Ryzen, it can give you a read.
https://bbs.archlinux.org/viewtopic.php?id=255535