Rustdesk Keyboard not Typing on Remote

I just installed rustdesk as an alternative to TeamViewer.
From my iPhone it is working great, there is a keyboard button bellow the app and I can use my iPhone keyboard to type on remote desktop.

I have to laptops, the main one which is EndeavourOS, and the one that I am accessing remotely with MX Linux installed.

I can access the remote desktop, move the cursor, click, right click… working as expected but keyboard on this EndeavourOS is not passing anything to the remote desktop.

How can I fix that? Is the problem related to the EndeavourOS or to the remote laptop with MX Linux?

Any guidance or help will be highly appreciated

1 Like

You could begin investigating your issue here:

Thanks @ivanhoe
The link is mainly about how to build/install… etc.
I have been searching and read on several websites lots of solutions, some take about KDE Plasma configuration on both machines, some say Keyboard on the machine I am accessing from should be same configuration as keyboard on the remote machine… !
Both, I didn’t even get what they are talking about.

For example:

RustDesk does not support Wayland. Check this to configuring Xorg as the default GNOME session.

Example 2:

Wayland does not seem to provide any API for sending keypresses to other windows. Therefore, the RustDesk uses an API from a lower level, namely the /dev/uinput device (Linux kernel level).

When Wayland is the controlled side, you have to start in the following way:
sudo rustdesk --service && rustdesk

rustdesk-dependencies as per AUR:

1 Like

The information you provided above is asking us for a crystal-ball… :crystal_ball:

Did you try ‘rustdesk-nightly’ from aur? I think I had this issue and that fixed it.

1 Like

This what I read and seems the same for me! This is why I said:

I did, have nightly on both now, but still no way.
Maybe I will try to find another app.

You are on KDE Plasma, right?

Have you looked at: ?

:exclamation: Disclaimer: I have no experience of this application so my post is merely informative

1 Like


I really appreciate your care to help at least. Thank you.
I am looking at it now.

1 Like

I don’t have time to test it out. But I had issues with Linux, maybe it doesn’t work well between Linux and Linux, as I remember I couldn’t even connect to a Linux remote a few months ago. If you have mouse input you could try an onscreen keyboard though.

I need it only to control Windows. I just remebered, my issue was, that I couldn’t type on Windows.

Did you install the nightly build on the MX linux side too? If you can type on a windows remote, maybe the issue is on the mx remote side.

Also if it’s your machine, set up some wireguard or tailscale and connect with vnc or rdp.

1 Like

I thought of this but thought to keep it as last resort!

Yes, both are nightly builds.
It seems to me that

This is so techie for me.

I will install a keyboard on the MX to use instead
Thank you very much

It just means you have to start rustdesk in service mode with that command on your remote system. Did you try that command?

edit: that command on the remote system, not local

1 Like

I tried. I ran it and nothing happened, I even did not get the app launched, I did not have a cursor. Launched it manually, but still didn’t work.

It is ok, I will take your suggestion and use a ‘software’ keyboard

sorry I wrote it wrong before, that command is for the remote side.

No problem. I will try later. Got a little busy

hmmm… From my iPhone I can connect and get the keyboard of the iPhone and type normally on the remote laptop (MX Linux)

So, It is accepting the keyboard input of the iPhone, can I say it is the keyboard in EndeavourOS that is not connecting or sending to the remote laptop?

Some settings or configuration to allow typing to remote laptop?

It’s probably an issue with the application. Not much you can do. Report it on github.

1 Like

In the application! How is that if it is working from iPhone? Or perhaps a problem with the app in connecting between 2 KDE Plasma desktops?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.