'RStudio' or 'RStudio bin' Do not Start

Dear Friends

For a few days ‘rstudio-desktop’ AUR is not working on my system, though R is working fine. I tried with the binary version ‘rstudio-desktop-bin’ AUR. But that did not start too. Application Menu Link ‘RStudio’ is not working.

Issuing ‘rstudio’ on the command prompt is giving this result:

rstudio: error while loading shared libraries: libboost_chrono.so.1.80.0: cannot open shared object file: No such file or directory”

And R is working fine. First I reinstalled ‘r’ and ‘rstudio-desktop’ both after removing them ‘yay -Rns’. But none of the package or its binary version did work. The Binary version ‘rstudio-desktop-bin’ gave a lengthier error message – like ‘no errors anywhere’, ‘nothing in log’ with some suggestions about what can I do like reinstalling ‘r’ and ‘rstudio-desktop-bin’ after doing ‘-Rns’ that I worked in several iterations with nothing doing. :confused:

And I know nothing about development to tinker with the library files like the reported one ‘libboost_chrono.so.1.80.0’. What can I do now? :thinking:

All this time R is up and running. Thanks in advance.

The rstudio-desktop package was just updated to include a patch needed for the recent update to the boost package. Update (or reinstall) rstudio-desktop, it should work now.

(The -bin package has not been updated)

1 Like

Thank you Stagger_Lee:

It worked. Before your suggestion I went more than twice through the removing and reinstalling all, but this time when I was asked if ‘soci’ and ‘rstudio-desktop’ are to be built anew I said yes. This did the thing. It took an infinitely long time to recompile, and so I was late to report.


1 Like

The package was just updated with the patch shortly after your first post. :wink:

Oh, that was the twist in the plot: I got surprised a bit – I thought you were the good luck charm. :disappointed: Thanks anyway.

1 Like

I have been accused of many things, but this is the first time I’ve ever been accused of causing good luck. :laughing:

1 Like