Rpi4 Installation Menu doesn't start

Hey folks!
After setting up my laptop and Desktop with endeavouros, I thought it would be a great ideal to push this beauty to my Raspberry Pi 4 8GB too.

After many attempts (method 1-3, each of them), I was always stopped when I was greeted with the initial boot setup screen.

What I figured out so far, is that as soon as I am connected to the internet via either Wire or WLAN, the Start Installation (and basically every other application like Terminal, Firefox etc.) won’t open up at all.

Disconnecting from network and clicking the button initially opens up Calamaris and reconnecting seemed to work then, but after that I was stuck in the keyring shell script…

Any ideas here?

I somehow solved it, but the whole process is a bit wonky to be honest.
Initially Calamares only opens up when being disconnected from any Connection - so disabling Wifi and wired connection solved starting into the setup progress.
After it started, reconnect to the network connection and progress until the keyring scripts are starting.
Disconnect from internet and reconnect shortly afterwards solved the stuck scripts for me immediately.

Welcome to the EndeavourOS forum. I hope you enjoy your time here.

Thank you for your feedback, it is appreciated.
Sorry your first encounter with EnOS ARM was a little wonky.

After me and the wife get back from our Valentine’s dinner this afternoon, I will look into this and see if I can recreate your problem. I will also probably create new RPi 4 images as they are getting a little stale.


1 Like

I created new RPi 4b images and released them on Github.

There were a couple of fixes in the new images.
For testing I did the following

Test Hardware
RPi 4b 8 GB RAM with eeprom at the current version.
Hard wired Keyboard and Mouse.
32 Inch TV with HDMI.

Method 1 - using Galileo Neo, I installed on brtfs with Gnome. I booted the RPi 4b using WiFi. All went as expected with no hiccups.

Method 2 - Downloaded the ddimg and used gnome-disk-utility to burn the image to a uSD.
Used KDE Plasma for a DE. All went as expected with no hiccups.

Method 3 - Used wget to down load the image-install-calamares.sh script. Installed on ext4 with Cinnamon as the DE. All went as expected with no hiccups.

Since you was able to get EnOS installed on your RPi-4b, you may want to keep on using it as is. Speaking of which, how did it run for you after the wonky install?

If you want to tinker around and re-install using the new images, let me know if your install issues were take care of.


1 Like

Hey Pude - thanks for your answers, updates and testing!

How was you Valentines dinner yesterday? Sadly my girl is sick in bed, so our options were limited.

So far EnOS is pretty stable on my Raspberry and I didn’t have any issues for now. I’ll try to search for another SD card in my cupboard later this afternoon and see if the new images erased my issues, so I don’t have to erase my working setup :smiley:

Cheers and Thanks!

1 Like

Great! I had a Filet Mignon with what they call the Fontina toppings. Which is:
Wood-grilled, topped with Fontina cheese, garlic, bacon and
mushrooms in a marsala wine sauce reduction.
flash-fried brussels sprouts tossed in a sweet and spicy kung pao sauce,
topped with toasted macadamia nuts and fresh cilantro. Also a garden salad.

We hope she gets well soon.

Thank you for offering to do some test installs. All feedback is appreciated.

I don’t know how experienced you are with Archlinux ARM devices, so I will err on the newbie side for now.

One thing I highly recommend is editing the /etc/pacman.d/mirrorlist config file. At the top of the file is:

## Geo-IP based mirror selection and load balancing

comment out the SERVER url
then un-comment a few mirrors closest to your location.
I am located in Colorado USA, so I un-comment the Florida and New Jersey mirrors.

If you are just going to tinker around with the RPi 4b, the uSD card will be fine. If you start to use the Rpi for a low power computer used for daily chores, then I recommend checking if your Rpi has the latest updates in the eeprom, and running off a USB 3 SSD enclosure.

To check the bootloader version in the eeprom use pacman to install the rpi4-eeprom package.
There is also a rpi5-eeprom for the RPi 5 device.

sudo pacman -Syu rpi4-eeprom
sudo rpi-eeprom-update

rpi-eeprom-update will list the two binaries in the eeprom and tell if they are up to date. If not it will list the current version.

If you need to update the eeprom, while connected to a reliable power supply,

sudo rpi-eeprom-update -a

But you probably already know all this.

Here is my setup


Actually this is my RPi 5 setup, but the RPi 4 setup is identicle.



That sounds really fantastic! Great that you had a nice evening.

Doing way better now - the cold in addition to her pregnancy didn’t make it easier for her, but she’s on her feet again.

I’m currently flashing the new images on a fresh card. Will check that later in the evening, since I’m out for the day going climbing. We’ll have dinner later, so I guess I won’t be able to get back to you today.

I think putting me on the newbie side for Arch and ARM wouldn’t be a wrong call. Worked quite extensively with different ARM Boards in the last years, but Arch is a new experience for me.
Thanks for the hint about the mirrorlist - I will take that into consideration, when I start the test-installation.

The eeprom was just updated again, before I started the last intallation attempt :slight_smile:

Thats definitly a tidy RPi Setup - are you using the RPi for daily chores?


No worries. We have few rules around here, but here are the important ones.

When it comes to volunteering one’s time

  1. Family comes first
  2. The job and/or school comes second
  3. EndeavourOS comes somewhere further down the line.

For about the last 4 years I have been using my RPi 4b for maintenance of the github EnOS aarch64 repository and well as development work.

For about 6 weeks now, the RPi 5 has taken over maintenance of the github EnOS aarch repository, and I now do all the compiling and most development on the Radxa 5B.

I live in the shadow of the Rocky Mountain eastern foot hills. I used to do a lot of hiking and a little first level climbing. Nothing that required equipment, but did a little scrambling once in a while. I have climbed 7 of the 54 Fourteeners in Colorado. I just wish I had arrived in Colorado before I did. Maybe my fourteeners list would have been a little longer. However, at 73 I just don’t have the stamina any more.


1 Like

Lovely - this community is probably even better than the OS itself.

I’ve found some time to test install the enosLinuxARM-rpi4-latest.img.xz using Method 2.
Connected to the WiFi and started the installation process. Worked like a charm. Every Application that didn’t open before (Firefox, Bash, Installation) loaded up immediately.
The default Global IP mirror made some trouble again, I’ve let the installer run for rougly 10 Minutes without any progress. I’ve cancelled the installation, removed the packman db lock file and changed the mirrors to use any near me (Germany in my case).
Started Installation again and it worked flawlessly.

Thats a really nice setup you’re having there. I mostly used the RPi for building up a PoC Conference Telephone that connected to an Voice Recognition Server running in a local network. Didn’t work out that good, because Voice Recognition wasn’t that far advanced 5 years ago.

That really sounds fantastic. Living in North Rhine Westphalia real Mountains are quite a long ride for me, so I’m mostly stuck in Climbing Gyms or some more local old stone pits. I’m planning to visit Arco in Italy in the next years, but since I’m going to be a father this year, I have to see how realistic this plan will be.

Thanks a lot for your help Pudge!

1 Like

Thanks for the test installs and the feedback. It is appreciated.

Be patient, you still have the rest of your life for things like that. Who knows, maybe you and your adult child will visit there some day.


1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.