Rolling back to previous nvidia versions

Hello, firstly apologies if I’m breaking any rules. I’m not quite sure where exactly to post this. I’d be grateful for any help with this. I’ve been trying to no avail for quite a few hours.

I’m attempting to roll back my nvidia driver version as some games I want to play don’t seem to run well (or at all in certain cases) with the new 545 version. I’ve followed the advice in a previous discussion, so I used the command

sudo downgrade nvidia-dkms nvidia-utils nvidia-settings opencl-nvidia lib32-nvidia-utils lib32-opencl-nvidia libxnvctrl

Upon rebooting it gets to past the startup screen with all the green OKs, (yes, a bit of a newbie with the terminology). and then the screen freezes there. The changes can be reverted just fine by logging in from a different tty and updating all the above packages back to their current versions.

Are there any established protocols for downgrading graphics driver versions or am I better off just starting fresh?

This will pretty much end you up where you are with the updated package. I’m not the best myself at explaining stuff but maybe if you can link what games are having issues and some system information others will be able to point you in the right direction

1 Like

Hello, thanks for the quick response! No trouble at all, I’m happy to get any help. There are a couple games, but the one I’m primarily concerned with is the new Persons 3 reload. I’m running the game using proton 8, but I’ve also tried GE, 7, and experimental and they all turn out the same.

The game starts up just fine, the menus and such work without a hitch. Upon starting a game there’s no issues either until I change scenes/enter a new area. Doing this crashes the game and I receive an “Out of video memory trying to allocate a rendering resource. Make sure your video card has the minimum required memory, try lowering the resolution and/or closing other applications that are running exiting” error message.

Just to sanity check I booted the game on a different laptop without a graphics card, (also running endeavouros and the same version of proton ) and the game runs fine. Browsing some forums online it does look like this memory allocation bug is an nvidia thing but I could be wrong.

That’s the whole background of why I’m trying to test older versions.

System Info :
Kernel: 6.6.15-2-lts
Graphics card : NVIDIA gtx 1050 mobile
CPU: Intel i7-8750H (12) @ 4.100GHz

edit : I’ve also turned the setting down as low as they can go to see if that would change things but this also still leads to the same error.

Seems to be 2 people reporting similar errors, maybe look at the results under these to see if they help at all

EDIT (under filter select GPU Nvidia)

Thanks again for the quick response. I’ve gone through the protondb recommendations, such as the launch options


Still no dice, the game still runs out of video memory upon the first scene change.

There’s someone with the same driver version for whom it is apparently working fine, but his card is a lot newer than my old 1050, so I suspect it can power through although I could be wrong.

did you try the regular kernel? It currently is at 6.7.3 - Does it show the same behaviour?

1 Like

Just tried it right now and no luck there either. Still the same error as well.

another thing that could possibly help is install steam-native-runtime and then run steam with the newly created native - shortcut. It uses Arch’s libraries then instead of the steam-bundled ones. If it does not change anything, you can either remove it with sudo pacman -Rns steam-native-runtime or just leave it installed for future tests - just use the regular shortcut to use the steam-runtime. Personally, I only use native, but I have an all AMD system.

Thanks for the suggestion. Didn’t know this existed, however the problem still persists. Apologies for taking up your time with this.

Yes, I’ve been on that thread. I’m actually the bloke trying to switch driver versions. Which is originally what I came to ask on this forum!

Just an update before I head to bed for tonight. I’d still be grateful if anyone could show me how to switch driver versions, just because that’s a thing I haven’t tried yet. Thanks again for all the help so far.

What you did originally should have worked. I wonder what are the versions of all the software that you tried to downgrade were. Maybe there was a version mismatch somewhere that caused your system to get stuck on reboot.

Thanks for the reply, I’ve changed them all to 535.111.01. Would you happen to have any clue as to what other packages might need downgrading/tinkering?

Nope, I think you got all of them.

Thanks for the response. It looks like downgrading is a lot harder than I figured it would be.

Out of curiosity do you think it’d make a difference if I tried Wayland? I’m currently using KDE with x11.

Normally downgrading is pretty straight forward but low level packages such as drivers can be an issue. I would recommend not using wayland until plasma 6 and the nvidia 550 driver come out. Me and a few guys have been beta testing plasma 6 and I specifically have been beta testing the nvidia 550 driver and both of these updates will solve a whole slew of peoblems that you will run into on wayland with nvidia.

Hello folks,

For downgrading the nvidia drivers, switching from KDE to i3 worked for me. I suppose there was some dependency in one of the KDE packages that caused it to not work.

For the Person 3 reload issue, the issue was resolved in the latest bleeding edge version of proton. The steps to use it are within the github issue posted above.

Thanks for all the help fellas! I’m a bit of a newbie too so thanks for being patient with me as well.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.