Right-click on window titlebar shows only icons

When I right-click on a window title bar I only see some icons and the menu spreads over the whole screen like this

Normally I would assume that I see some text menu items (maximize, move to desktop…). I’ve been looking around in the settings but haven’t yet found a clue how to change that.

Can somebody help me? I’m using plasma-desktop 5.26.5-1 but I’m not sure if you need more information about the versions of other packages.

Thanks, Jens

Works as expected here. KDE was updated yesterday to the version you have. Maybe, if you haven’t already, do a reboot and see if it helps

image

I rebooted several times but unfortunately nothing changed. As before I only see the icons without text.

Not sure if this is somehow related: I recognized that after reboot and login the control bars on the bottom of the screen are missing the icons. That looks like this:

When I restart plasmashell like this: kquitapp5 plasmashell || killall plasmashell && kstart5 plasmashell it looks normal:

If you make a new user and login with it, is it then working as it should?

1 Like

I’ve created a new user but encounter the same problems. I’ve also tried to logout and login again (with the new and with my main user) but the problem still remains.

I’ve just realized that all my windows are missing their titles in the title bar. This is an example of a firefox windows title:


This also looks strange to me.

As the new user also fail, there is not much hope with this:
If you open Systemsettings - Apperance and set a default theme like Breeze, if you aren’t already using it.
Then hit, at the bottom, the buttom “Defaults”
Does that bring back the titel and the missing text.

Else you might test if reinstalling
plasma-workspace
helps anything.
I have never tried that. I don’t know if it will change anything.

I’ve tried that but it didn’t help.

After that I’ve been able to nail down the problem to DisplayLink. I’m using a laptop with a USB docking-station. When I use the laptop stand-alone everything works perfectly fine as excepted. When I plug in the the docking station the title bars suddenly disappear and the context menu is broken. When I unplug the docking station everything goes back to normal.

Sorry that I didn’t mention that I use DisplayLink and that I didn’t test the laptop stand-alone before writing in this section of the forum.

Do you guys say to mark this thread as solved or can it be moved in another section of this forum? I’m a newbie in Arch and Endeavour so please excuse me for this stupid question.

Anyway @HCHR thank you for your help so far.

I’d either start a new thread or edit the title of this thread so that it refers to DisplayLink.

Read the Latest Comments for both of these packages:

https://aur.archlinux.org/packages/displaylink

https://aur.archlinux.org/packages/evdi-git

Also, read the Known Issues for the DisplayLink driver for Linux:

https://support.displaylink.com/knowledgebase/articles/641668

Sorry that I ask. I’m not able to edit the thread title. I only see an edit button in my recent posts but not for the first one. Can you tell me what to do?

If you see a pencil icon to the right of the title, it allows you to edit the title. However, as a newer member of the forum, you might not yet have that permission. So we can ask a moderator to do it for you:

@ricklinux, would you please edit the thread title to include a reference to DisplayLink? Also, would you please move the thread to an appropriate category, since the topic really has little to do with Plasma? Thanks!