Returning to KDE: Centered Panel & Autohide Tips?


Currently, I’m using Gnome but would like to switch back to KDE because that’s where my heart belongs.

The problem is that I really want to have my panel centered and shortened with intelligent autohide, but it seems that this feature is not working with the standard KDE panel.

Before, I had been using Latte-Dock, but it now seems to have many glitches and bugs because it’s no longer maintained.

Do you guys have any suggestions on how to make the move back to KDE?

Can you describe what isn’t working the way you expect.

You can easily make a panel centered that doesn’t consume the whole width and have it autohide.

Something similar to the following?

Somewhat Windows-eleven-esque :wink:

I don’t find any option for intellihiding but only for autohiding the panel.

Auto hide is broken & hasn’t worked properly on my system for months now. It is a confirmed bug in KDE

That bug report is from 2014 and some people still report having issues with this :astonished:

Anyways, I did the above on a test system on real hardware that I keep around to just take a peek at once in a while. During this test of let’s say 15-20 minutes, I configured the bottom panel as per request in the OP.

Auto-hiding seemed to be working during this short period but I couldn’t find any option for intelli-hiding entering the edit mode and looking at more options.

I haven’t though read through the whole of the bug report and not tried to reproduce it.


Yer it worked for quite a while for me but I have made that many changes & it may have even been broken before I noticed as my panel is on a screen I don’t use too often. The same bug seems to also effect windows can cover option.
Edit. I just tested with a new user and setting the panel centred and with Auto hide & windows can cover works so if @siial wants they could probably setup to how they like it as long as they don’t make too many changes/take note of what they change so they can see what if anything breaks it for them.


I installed KDE this morning to try out the dock. It seemed to work quite well initially, but after a while, the dock started behaving oddly.

When the dock comes up, there’s some noise in the effect that causes it to lag slightly. (XORG)

Auto-hiding works, but it seems to stop working when you receive a notification in an app that’s pinned to the bar. The dock doesn’t hide until you open the notification.

intelligent Auto-hiding is a nice feature that hides the panel only when something collides with it. However, I bypassed this feature by setting a small top panel with information, and it works quite well for me.

I suppose I’ll stick with KDE for now and hope that Plasma 6 will bring some more exciting features. You can’t have everything in the world, haha.

Have you tried checking the task manager settings and ensuring that Behavior->“When panel is hidden”->“Unhide when a window wants attention” is unchecked?

1 Like

Just installed Latte Dock, a few weeks ago. Even though the process of installing and customizing wasn’t error-free at all (several crashes and reboots with some patience involved), it has kept working fine, ever since I set it up on my KDE with WhiteSur theming:

Nate has just announced, that the intelligent “windows can cover” mode gets deprecated, and another, very similar feature gets implemented.

The only thing you can do right now, is using X11, as that has far less issues with the “windows can cover” setting.