Resume hook missing even if installing selecting hibernate to swap

I installed Endeavour OS on 3 different devices, using the latest 2 ISO (so the bug is definitely still there). I selected Hibernate to Swap, but trying to hibernate would also result in failure, and the system would simply go in standby.
I realised that the resume hook was simply missing, so adding “resume” to the path mkinitcpio and reloading fixed the problem. I suggest the dev add it automatically if the hibernation option is selected during installation.
Also this works on grub + mkinitcpio. I also had an install with systemd-boot + dracut. Same problem but adding the hook “resume” didn’t solve anything. I did follow the offical guide on archwiki but nothing, so I switched back to grub + mkinitcpio and it finally worked.

PS, I am a Linux enthusiast, not an expert of the Linux kernel, so please don’t flame me if I wrote something which is not quite correct.

1 Like

We are looking into resume issues with Cassini. Thanks for reporting it.


Awesome thanks! Also if you could understand why adding the resume hook with dracut doesn’t work that’d be great! Really don’t like grub much, would be sweet to go back to systemd-boot!

Check this post for a solution.

Nice thanks! Will try next installation :slight_smile:

How did you rebuild dracut? You need to use sudo dracut-rebuild.

if the module is not build in the initramfs it can be added added to do that on already installed system too no issue and no need to reinstalll the OS.
As in the post @2000 mentioned:

first generate the dracut configuration file for hibernation:

cat <<-EOF | sudo tee /etc/dracut.conf.d/resume.conf
add_dracutmodules+=" resume "

and regenerate initramfs

sudo dracut-rebuild

you can add the line:
add_dracutmodules+=" resume "
also to the already existing eos dracut config file:


and regenerate the images:

sudo dracut-rebuild

so you do not have multiple files to track …

I did try that but it did not work. Will try again and maybe get the logs too.
As for the resume missing, I feel like it is a bug as selecting hibernate during the installation process should result in an actual working hibernation!

Yes, we are working on fixing it. Support for it needs to be added to the installer so it won’t be fixed without changes to Calamares and a new ISO.

1 Like

it is a BUG that it is not enabled yes… but it should work when you enable it, if this is not the case something else is interfering with your system, could be also related to firmware settings.
In some cases, hibernation is not working at all on specific devices.

So to check if resume is enabled in the kernel image check it:
lsinitrd | grep resume could show

If it moan on you that it does not know where to search…
you need to use lsinitrd -m <path-to-your-initrd> | grep resume

will be something like:
lsinitrd -m /efi/75438975987345987/6.1.7-arch1-1/initrd | grep resume

what shows resume as output if the module is enabled.

I tested this on several devices without issues.
systemd-boot and grub efi and legacy…

thank you so much! I confirm it does work with grub + mkinitcpio, though I haven’t tried with systemd-boot and dracut given that I wiped that installation. Looking forward to the next release, thank you for your great job :slight_smile: