Restart not possible with seemingly a GPU/Driver issue? AMD/Radeon RX 7700 XT

Hi there,

first post, I hope I’m doing everything correct. eos-sendlog is awesome.

I already posted this on reddit, but the forum seems much more active.

The System:

I’ll try to sort the information as good as possible:

The Symptom: The PC is unable to restart when clicking “restart” and also won’t work if I click “shutdown” and turn it back on.

Specifically, and this is why I am very lost on this one: The VGA-Led does not turn back on when the PC restarts and I am not even greeted with the Mainboard-Boot-Logo so neither journalctl or dmesg are helpful on this one, I checked both.

I am able to start the PC and the OS when I switch off the Power Supply, wait until the fancy RGB goes out and then turn it back on.

It also works if I boot into a different OS, namely Windows 10. All three (+Manjaro, will test later) are installed onto a single M.2.

The Timeline: I’ve upgraded my GPU on the 30th of December from a RX 5700 XT to the RX 7700 XT. Everything worked fine, including restarts until I noticed the inability to restart the system today.

I was on a business trip from 1st of January until the 5th of January and thus did a system update through pacman -Syu yesterday. Sure enough, vulkan radeon got updated as well:

$ grep -i upgraded /var/log/pacman.log | grep radeon [2024-01-06T19:47:23+0100] [ALPM] upgraded vulkan-radeon (1:23.3.1-1 -> 1:23.3.2-2 [2024-01-06T19:47:23+0100] [ALPM] upgraded lib32-vulkan-radeon (1:23.3.1-1 -> 1:23.3.2-2)

This has lead me to believe it might be a driver issue as the card is properly seated (even when trying with a riser) and the other PCIe-Slot works fine as well. Which means it is only the first PCIe-Slot, which is also 4.0 instead of 3.0.

However, downgrading both libraries did not solve the problem:

$ grep -i downgraded /var/log/pacman.log | grep radeon [2024-01-07T11:29:05+0100] [ALPM] downgraded vulkan-radeon (1:23.3.2-2 -> 1:23.3.1-1) [2024-01-07T11:29:21+0100] [ALPM] downgraded lib32-vulkan-radeon (1:23.3.2-2 -> 1:23.3.1-1)

The Problem also persists if I put the PC to sleep and try to wake it up again.

I then tried restarting and the problem is still there. I do not know where to continue searching, any help is highly appreciated.

Check journalctl -xe logs for any error messages or warnings related to the graphics driver or system shutdown/restart.

Ensure that the GPU drivers are loaded correctly. Use the following commands to check for loaded drivers:

lsmod | grep amdgpu
lsmod | grep radeon

Also, If the issue started after a kernel upgrade, consider rolling back to a previous kernel version to see if the problem persists or try the LTS kernel.

The PC didn’t even post, so I doubted it would contain anything useful. And also, it didn’t.

The problem seemingly fixed itself with the new Mainboard, even though that makes no sense to me.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.