Replace partition installer option crashes it

I’ve looked at the hardware of this laptop and i see absolutely no reason for the issue. How are you creating the live ISO? There are only 3 options. If you didn’t touch the windows partition you can use install alongside and it should automatically resize the Windows partition and install on the same drive. If you resized the partition in Windows using disk management then you can use manual partitioning or you could format that partition and then use replace partition. I see no reason that the hardware would cause it to fail. It does matter how the live ISO is created.

this could be something related to mesa p.e. we had an issue with the installer over some time but testers and devs was not having this issue anymore with the latest mesa versions.

But you could check downgrading mesa on the live session… and I could give you a link to a fresh rebuild.
@ng0177 we would happily have you in ISO testers group also if you have time to help testing.

Right. I have now (edit) tried to install EOS on an Intel/NVIDIA workstation and it fails. This points us to the boot stick.

I have created a new GPT partition on an not too old stick and used FedoraMediaWriter under CentOS 9: installer crashes.

I have also tried another boot stick and same story. Gparted back and forth paritition deletion etc. has also been fully investigated.

Since I have now (edit) immediate need to use EOS, I will wait until others report the “replace partition” problem, too. Because I tested different hardware scenarios, it seems likely more reports will come in.

I have very little time but still happy to help and see, if downgrading mesa works. Please go ahead.

i can go try to reproduce if it is about the FedoraMediaWriter … but the ISO is out for a while already and I see a lot users not have any issue like this… i do testinstalls every day to, we have done a lot of testing before relasing ISO.

I used replace partition on dual boot Windows on 4 different computers with one also having Nvidia.

yes i do some tests using the mediawriter without any issue… too…

I have been doing my tests on two laptops and one workstation all of which are max 1 year old hardware.

using then the second option “(…Nvidia)”?

it is a strange issue… and if not gpu/driver related I have no clue as it looks like also a different usb stick does the same on different systems.

Could be a rare case where the iso image used is corrupted, or an issue with the host used to write the sticks. or 1001 other things … so far I have only reports rarely about it somehow stuck on bootloader screen… what is where we had an issue on AMD GPU before and downgrading Mesa was working.

But if it is exactly what you say about clicking on the partition with replace option is crashing calamares and it is reproducable only on you not much we can do.

Only thing is I can send you a link for a newer ISO to test?

Yes, let us try that.

As it happens, the newer ISO works flawless on

  1. Intel/NVIDIA workstation
  2. AMD/Radeon gaming laptop
  3. AMD/Radeon standard laptop

as discussed above. For a change, I did use Mediawriter unter Fedora not CentOS this time, so the root cause is not clear but it does not matter too much upstream.

Appreciate the swift support and resolution as always.

1 Like


Edit: So you tried one of the newer ISO from @joekamprad


1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.