Remove unknown boot entries found after updating grub

So here’s something i can’t understand either. On my Cinnamon dual boot Win 11 I reinstalled grub after the updated grub package and ran the grub update command. This is what it did to the path and this didn’t happen exactly the same on the other 4? So it added folders for arch, Arch_Linux, endeavouros, Manjaro, and Microsoft. What the hell? On my other Lenovo it added even more stuff. Is it because of the way i installed grub? I installed it to the efi partition on all of my systems. They all work but this is just strange.

sudo grub-install /dev/sda1

Others are different device names obviously.

Edit: This is on the Lenovo and the one above is on my HP.

Edit: These two systems have Win 11 with a partition for eos and they are ext4.

On the two desktops that have separate drives it only added the endeavouros folder?

1 Like

It seems not, but you should investigate.

ls -gG /boot/efi/EFI/.
find /boot/efi/EFI -name "*.efi" -exec ls -gG '{}' \;

Have you ever tried to clear old folders from those $ESP partitions?
Were any relevant distros installed, and which ones?

It’s possible i had other distro’s on them at one time but can’t recall for sure? Windows 11 is on them.

Windows 11 isn’t a Distribution :stuck_out_tongue_closed_eyes:


I feel you. I also have memory issues (not RAM).
The proposed commands will help your memory. :wink:

Do i really need to know that? No!


[ricklinux@eos-cinn ~]$ efibootmgr
BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0001,0005,0004,0000,0007,0003,000C,9999,0002
Boot0000* Windows Boot Manager	HD(1,GPT,e8e61be8-2572-45f8-9b53-984aac714ba1,0x800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)57494e444f5753000100000088000000780000004200430044004f0042004a004500430054003d007b00390064006500610038003600320063002d0035006300640064002d0034006500370030002d0061006300630031002d006600330032006200330034003400640034003700390035007d00000000000100000010000000040000007fff0400
Boot0001* endeavouros	HD(1,GPT,e8e61be8-2572-45f8-9b53-984aac714ba1,0x800,0x32000)/File(\EFI\endeavouros\grubx64.efi)
Boot0002  Linux Boot Manager	HD(1,GPT,b6f3f68c-d7e5-4421-87a9-44f4548c3238,0x800,0xff801)/File(\EFI\systemd\systemd-bootx64.efi)
Boot0003* rEFInd Boot Manager	HD(1,GPT,d1930251-4caf-4b74-b76d-a56cdc7e616d,0x800,0x32000)/File(\EFI\refind\refind_x64.efi)
Boot0004* arch	HD(1,GPT,e8e61be8-2572-45f8-9b53-984aac714ba1,0x800,0x32000)/File(\EFI\arch\grubx64.efi)
Boot0005* Manjaro	HD(1,GPT,e8e61be8-2572-45f8-9b53-984aac714ba1,0x800,0x32000)/File(\EFI\Manjaro\grubx64.efi)
Boot0007* Linux Boot Manager	HD(1,GPT,3c448293-9673-4f92-a602-11ddac197204,0x800,0x1f4000)/File(\EFI\systemd\systemd-bootx64.efi)
Boot000C* Internal Hard Disk	PciRoot(0x0)/Pci(0x2,0x4)/Pci(0x0,0x0)/NVMe(0x1,8C-E3-8E-04-01-12-60-54)/HD(1,GPT,e8e61be8-2572-45f8-9b53-984aac714ba1,0x800,0x32000)0000424f
Boot9999* USB Drive (UEFI)	PciRoot(0x0)/Pci(0x1d,0x0)/USB(16,0)0000424f
[ricklinux@eos-cinn ~]$ 

Okay so how do i go about removing these without causing boot failure?

Edit: I can use efibootmgr to remove the entries? Then can i just remove the folders? Or do i need to update grub again after that?

Edit2: I know they aren’t hurting anything. I had just forgot maybe i had installed these at some point?

  1. Delete folders that include bootloaders for systems they no longer exist
  2. Delete the UEFI entries that point to files that do not exist (after previous clean-up).
  3. Confirm the preferred bootloader is first in UEFI entries (efibootmgr)

What about the Microsoft Folder? I do have Win 11 as dual boot?

Edit: Btw I’m not great at some of the grub issues although i do use it and can overcome some issues.

1 Like

Is the second sentence a question or affirmative?
If you have WinOS, keep it.

I missed a warning.
Double entry “Linux Boot Manager” is on two different $ESP partitions. Not the same.

Yes i do have Win 11 and probably eos has it’s own efi partition. Unless i used manual partitioning it gets created i think from Calamares installer.

EnOS usually has a branded filename, not the usual arch/grub, which is created when not using --bootloader-id with grub-install.

Yes, but i thought things got changed and it wasn’t using the naming anymore? :man_shrugging:

Make a proper question so I can answer :man_shrugging: . My :crystal_ball: is on vacations.

I don’t honestly know how to ask the right question because I’m not sure how it’s set up to work exactly. So I’ll ask a different one. On my other Laptop which is the Lenovo it also is dual boot Win 11 and i see it has a folder called Insyde which i assume is from a UEFI Bios update. There is also one called Update Capsule which has a bin file in it which i think was when i tried using fwupdate and it added the UEFI security updates for ??? can’t remember what they call it? Can i remove both of these?

Edit: I think it’s the signed …whatever they call them?

I would not remove those. They are from the UEFI/vendor firmware.

Only deal with distros. They have *.efi files (bootloaders).

1 Like

After removing stuff do i need to run the grub update command?

IIRC yes. I think grub checks efi bin files and adds entries.
You may check your existing grub.cfg for such entries.

grep "\.efi" /boot/grub/grub.cfg
grep -i "insyde" /boot/grub/grub.cfg

Sloppy check. You may less /boot/grub/grub.cfg and look better.

On the HP

grep "\.efi" /boot/grub/grub.cfg
ricklinux@eos-cinn ~]$ sudo grep "\.efi" /boot/grub/grub.cfg
[sudo] password for ricklinux: 
	chainloader /EFI/Microsoft/Boot/bootmgfw.efi

It looks like it does only for Win.


sudo os-prober

This will show anything that will get into the menu, apart from the native distro.