Remove desktop icons

Can anyone tell me how to remove icons from a mate desktop?

1 Like

Hi @rewq
From the Arch Linux wiki:

Tip: If this option is grayed out and unavailable, try installing the mate-extra group.
Show or hide desktop icons
By default, MATE shows multiple icons on the desktop: the content of your desktop directory, computer, home and network directories, the trash and mounted drives. You can show or hide them individually or all at once using gsettings.

Hide all desktop icons
$ gsettings set org.mate.background show-desktop-icons false
Doing so may cause some graphics artifacts on secondary monitors.

Hide individual icons
Hide computer icon:

$ gsettings set org.mate.caja.desktop computer-icon-visible false
Hide user directory icon:

$ gsettings set org.mate.caja.desktop home-icon-visible false
Hide network icon:

$ gsettings set org.mate.caja.desktop network-icon-visible false
Hide trash icon:

$ gsettings set org.mate.caja.desktop trash-icon-visible false
Hide mounted volumes:

$ gsettings set org.mate.caja.desktop volumes-visible false
Replace false with true for the icons to reappear.

https://wiki.archlinux.org/index.php/MATE#Hide_individual_icons

ComplicatedWildKitten-small

5 Likes

Another option is to install Mate-Tweak (from AUR) and uncheck icons in the right section :slight_smile:

3 Likes

Thanks very much. this worked a treat.

Thanks for your advice but not needed as Elloquin’s solution did the job. Much appreciated.

Here’s how to hide Mate desktop icons. https://mydayswithlinux.wordpress.com/2015/08/12/how-to-hide-desktop-icons-in-mate/

Sorry I’m new to this and didn’t realize I had to tick the “solution” box. Thanks anyway.

1 Like

No problem. Other times welcome.