Remove accessibility icon in GNOME panel

I have scaled my font (2K monitor) and for this reason the accessibility icon is now displayed in the GNOME panel. Very nice if you want to see something like that. I don’t want to see it, especially since it is optically a faux pas there. Is there a way to hide it?

Bildschirmfoto vom 2020-10-16 17-11-09

Just to get the simple things out of the way:
check (gnome-) settings -> accessibility -> “always show menu…” (the toggle on top). is this set to “on” maybe?

Otherwise i don’t know, sorry

I have already switched that off. Anyway, it makes no difference how the switch is positioned.

Well it certainly works for me did you try logging out,

sure

1 Like

try changing the theme, remove extensions, and try again

The only extension is Dash to dock and themes I already changed.

1 Like

Well as I said it works fine here, switched on


switched off
you could try to turn it off using dconf Editor

Well, looks to me like it works as designed :stuck_out_tongue:
Tried it myself. if i switch on “large text” in accessibility the icon appears, no matter what.
Same happens if i go another route: gnome tweaks -> fonts -> scaling factor. If i change that, the icon appears as well…so i guess thats normal beaviour… You could maybe “force disable” the icon in the panel via some kind of extension, or need to dive into gsettings/dconf editor…maybe there is a chance one can get rid of the icon, but i’m not sure.

Thanks @T-Flips , I was afraid of something like this. Well, let’s see, I’ll get used to it sometime, or I’ll try to tinker with it.

As you do enable one of the accessibility helpers it is pulled on, that’s by design, but if you want only font to be bigger why not using tweaks to set the font bigger?

It is not only about the font. That would also be too easy. I have a 25" monitor with a 2K resolution (still), scaling is inevitable. Next year I will have a 27" monitor, also with 2K resolution. Maybe I can do without the scaling then.


so normal way is not working für dich?

Zitat: “Um den Hi-Dpi-Modus für den gesamten Desktop zu erzwingen, verfügt gnome-tweak-tool auf der Registerkarte Windows über ein Steuerelement für den Skalierungsfaktor”
Nichts dergleichen:

Bislang habe ich das über die Schriftenskalierung gelöst (wie auch bei XFce):

Jaaa, X ist nicht Wayland … An die manuelle Einstellung via

gsettings set org.gnome.settings-daemon.plugins.xsettings overrides "[{'Gdk/WindowScalingFactor', <2>}]" 

habe ich mich noch nicht heran getraut. Ich hatte bislang mit GNOME noch nicht wirklich viel zu tun.

gsettings set org.gnome.settings-daemon.plugins.xsettings overrides "[{'Gdk/WindowScalingFactor', <2>}]"

könnte dann wirken

GNOME ermöglicht derzeit die Unterstützung von hi-dpi, wenn die Bildschirmauflösung mindestens 192 dpi und die Bildschirmhöhe (in Gerätepixeln) mindestens 1200 beträgt.
Es gibt mehrere Möglichkeiten, dies manuell außer Kraft zu setzen und die Hi-dpi-Unterstützung ein- oder auszuschalten.

Ich versuche es mal mit

gsettings set org.gnome.settings-daemon.plugins.xsettings overrides "[{'Gdk/WindowScalingFactor', <1,17>}]"

Dh, 117 ist die Pixeldichte bei 2K auf 25". KA, ob sich das so übernehmen lässt. Wohl eher nicht. Muss ich mich rantasten.