Removable devices list is empty

The removable devices automount list in settings is empty, which is strange because I have 1 EXT4 drive and 2 NTFS drives attached which I can access through Dolphin. Other KDE distros I tried had them show up in the list. What gives?

If these three devices are connected to a SATA or NVME connector, then they are not removable devices.

Removable devices are devices that are usually connected to a USB port. Such as thumb drives, SD cards connected through USB.

I attached a USB Thumb drive labeled “DATA”, told it to notify “On Attach” and got this



That’s where they usually showed up, though, and it’s where I could automount them. Did Plasma change this?
Anyway is there another way of automounting these devices now?

I am not sure about the terminology you are using.
Automount means the devices are automatically mounted when you boot up / login without any action by the user.

For devices connected to the internal bus from SATA or NVME, this is usually accomplished with /etc/fstab.

For USB devices, udev usually recognizes devices either at boot up or when the device is hot plugged into the computer.

Is the ext4 drive automounted (probably is since EnOS must be there) and you want to manually mount the 2 NTFS drives when desired?

Most USB thumb drives are automounted when they are hot plugged in. If the USB device is already mounted at boot up, I believe udev recognizes them but doesn’t always automount them.

Here is where I hot plugged in a USB Thumb drive.

It displays that the thumb drive labeled “DATA” was automounted at hot plugin, and a new icon appears in the panel. As long as a removable device is mounted, this icon should be there.

If no removable device is mounted, then the above icon is replaced with the ^ icon. Hovering over this will “Show hidden icons”. Clicking on it will bring up a menu which includes the “Disks and devices” icon.

As to what changes were made in Plasma 5.27 perhaps more information would be available in the KDE Plasma forum. You might want to check there, or perhaps one of our users more versed in Plasma could chime in.


I misspoke, the 3 drives I mentioned are actually in addition to my main EndeavourOS drive.
I attached a USB drive and I still can’t get anything to appear on that list, something is amiss here.

I flashed a Manjaro (Plasma 5.26) and a Kubuntu (Plasma 5.24) live USB for testing. In Manjaro the list looks the same, but in Kubuntu it lists everything I have attached, even non-removable devices.

This is how I used it before, it’s an easy GUI way of adding fstab entries I suppose.

I tried again with a different USB device and it appears, I guess I had to tick a box to automount for it to show up? I don’t even know.

Edit: Everything appears now. I have no idea what triggered it, but it seems to have happened after I ticked the checkbox to attach all known devices and rebooted.

I am so confused, but I guess it’s fixed now.


I got the same problem on a fresh install - removable devices list stays empty (no boxes to tick). I tried with normal and LTS kernel, tried some USB-sticks and HDD’s without success.

kcmshell5 --list shows there is a module named kcm_device_automounter.
Is there a service I have to enable first?