Remmina FreeRdp Problem

Notice (i think it would be important.):I am using Endevaour OS with Xorg

I installed Remmina and his packages. It worked as well at first.
But when i tried to open a RDP Tunnel i faced with that error:

[22:54:45:417] [77632:77645] [ERROR][com.freerdp.core] - transport_connect_tls:freerdp_set_last_error_ex ERRCONNECT_TLS_CONNECT_FAILED [0x00020008]

How can i fix it? (If i need send my computer infos i dont know how to do in terminal or in any what. If you would say how to do i will.)

Did you check the Arch-Wiki yet?

I checked but i dont think it gives enough information

but i found a source for my solution but i dont know how i would do it. Can anyone help?

The message you provided could also point to a failed negotiation between the client and server - perhaps due to a self-signed certificate or an expired certificate.

Some time ago had issues with krdc on Wayland so I created a template script.

Among other things it uses a flag /cert:ignore to counteract the self-issued certificates on windows servers. The script is based on the commandline options described in the freerdp documentation

As there is a solution in above mention report you could use the script and add to the parameter list of script by inserting the pamameters in the beginning of the line

The line for wayland inject

/usr/bin/wlfreerdp /tls-seclevel:0 /timeout:80000 [...]

The line for xorg

/usr/bin/xfreerdp /tls-seclevel:0 /timeout:80000 [...]

If you don’t feel like scripting you can add the parameters in server properties on the Advanced tab



Oh thx if you would not send it. i would go dependency hell for downgrade openSSL i will try it!