Remmina don't works


Load modules from /usr/lib/remmina/plugins
Failed to load plugin: /usr/lib/remmina/plugins/
Error: cannot open shared object file: No such file or directory
Failed to load plugin: /usr/lib/remmina/plugins/
Error: cannot open shared object file: No such file or directory
Remmina plugin glibsecret (type=Secret) has been registered, but is not yet initialized/activated. The initialization order is 2000.
** Message: 15:43:38.845: [X2GO] X2Go plugin loaded.
Failed to load plugin: /usr/lib/remmina/plugins/
Error: cannot open shared object file: No such file or directory

(process:2193): libsecret-CRITICAL **: 15:43:38.846: secret_service_load_collections_sync: assertion ‘paths != NULL’ failed

here is the arch wiki about remmina maybe start there.

1 Like
$ pacman -Si remmina
Repository      : extra
Name            : remmina
Version         : 1:1.4.33-3
Description     : remote desktop client written in GTK+
Architecture    : x86_64
URL             :
Licenses        : GPL
Groups          : None
Provides        : remmina-plugins
Depends On      : avahi  libgcrypt  libssh  vte3  libsodium  libayatana-appindicator  libsoup3
Optional Deps   : freerdp: RDP plugin
                  libsecret: Secret plugin
                  libvncserver: VNC plugin
                  spice-gtk: Spice plugin
                  webkit2gtk-4.1: WWW plugin
                  gtk-vnc: GVNC plugin
                  kwallet5: kwallet plugin
                  gnome-terminal: external tools
Conflicts With  : None
Replaces        : remmina-plugins
Download Size   : 1089.91 KiB
Installed Size  : 5011.04 KiB
Packager        : Felix Yan <>
Build Date      : Sun 08 Oct 2023 06:54:42 AM +08
Validated By    : MD5 Sum  SHA-256 Sum  Signature

All the missing shared objects you listed are part of remmina’s optional dependencies. For some reason, your use case requires those optional packages, so you’ll have to install them for remmina to work.

1 Like

Thank you. But this is not a specific answer to a specific question. Remmina doesn’t work here. I ran it without problems on Debian12 (apt install remmina) and no problems. RDP works correctly on Debian.Show me someone whose remmina’s RDP works in arch.I looked up this issue on the Internet: there are only links to bugs in this program

What I’m suggesting is that you can install those missing dependencies first and then try to run remmina again.

This one is saying that you need the spice-gtk package.

This one is saying that you need kwallet5

This one is saying that you need gtk-vnc.

All of this packages are listed as remmina’s optional dependencies. remmina looked for those packages when it tried to run, and it likely failed because you didn’t have them installed.

Once again I will repeat: show me a specific person for whom remmina’s RDP works and show the screenshot.I can show you a screenshot of a working remmina on Debian

Well, since you posted a bunch of error messages on a forum, one would assume that you are looking for a solution to your problem.

What’s your point? I don’t have any problems believing your claim that it works on Debian. I was only trying to help you resolve the issue by offerring a solution. And also, why do you even need proof that Remmina works on Arch? Just read the error message and install the missing dependencies. And then you will have the proof that you want by seeing it work on your system. I don’t understand why you would waste time demanding “proof” when a possible solution is right there in front of you.

1 Like

I use Remmina on arch for work. It works. Install the dependencies and try again. Otherwise we can’t help you. Also it doesn’t matter if it works on our machines, you want it to work on yours. And for that you need to install the dependencies you are missing.

1 Like

In debian

In arch


What now?

1 Like

You deserve an award for your patience.

Dude, just run the following command and try again.

sudo pacman -Syu kwallet5 spice-gtk gtk-vnc

If you don’t want to try that why are you even here? Have a nice day.

@anthony93 yeah… I don’t know why I’m doing this…


Good luck trying to prove a point that nobody cares. Have a nice life.

1 Like

@I0F You’re too nice.

1 Like

Thank you, I’ll have time to try on Endever, while I launched Remina on Debian, very simply without unnecessary movements

Yes. Debian is the best. The best linux distro of all time. Thanks for letting us know.

Thanks, ater sudo pacman -Syu kwallet5 spice-gtk gtk-vnc all works

1 Like

The main advantage of Arch is that there is no release date. But Debian has this drawback, because with each new release you have to reinstall your data. FreeBSD is also good in this sense, I upgraded the release from version 10 to 11-12-13-14 without losing my data

Because they are different distributions with different packages and different philosophies when it comes to how things are done.

Although I did just check my Debian vm.

$ grep -i version /etc/os-release 
VERSION="12 (bookworm)"

$ apt-cache search remmina
remmina - GTK+ Remote Desktop Client
remmina-common - Common files for Remmina
remmina-dev - Headers for Remmina
remmina-plugin-exec - EXEC plugin for Remmina
remmina-plugin-kiosk - Kiosk plugin for Remmina
remmina-plugin-kwallet - KWallet plugin for Remmina
remmina-plugin-python - Python support for Remmina
remmina-plugin-rdp - RDP plugin for Remmina
remmina-plugin-secret - Secret plugin for Remmina
remmina-plugin-vnc - VNC plugin for Remmina
remmina-plugin-www - WWW plugin for Remmina
remmina-plugin-x2go - X2Go plugin for Remmina

It seems Debian needs plugins installed for some of those remmina features as well.

1 Like