Reflector error: The handshake operation timed out

I just installed Endeavour this morning and noticed that the download speed with pacman was very slow and unstable (something around 10.000kb/s and sometimes it just drops to 0b/s) but my connection was actually fine, so i figured out that it might be some kind of mirror problem and tried to use reflector.

I runned reflector --latest 5 --sort rate and this error happened:

error: failed to retrieve mirrorstatus data: URLError: <urlopen error _ssl.c:985: The handshake operation timed out>

I searched for it and coudn’t find a solution, i tried to increase the download-timeout but the same error happens. reflector-simple doesn’t work either, this error occurs:

image

I’m using USB tethering to get internet, cause there’s no internet cable in my room yet, maybe this is the problem but everything else works fine. I usually get 10mb/s of download speed, and that’s enough.

Sorry if there are some english mistakes or if something sounds strange, i’m brazilian and my english is bad.

Welcome to the forum! :smile:

You can try reflector option --connection-timeout 30 or even larger number.

Alternatively, you could try program rate-mirrors instead, e.g.

sudo pacman -S rate-mirrors
rate-mirrors --save /tmp/mirrorlist arch --max-delay=7200 && sudo cp /tmp/mirrorlist /etc/pacman.d/

I can confirm that rate-mirrors is a good possible solution as Manuel said.
However, I have to say, have you checked if the “default config” is good for you or is slow?
I had the same issue as you some years ago when I discovered and tried Endeavour - it’s not Wi-Fi related. This time, I could use reflector but many mirrors often times timeout, while other tools get the job done just fine. Also this time, the default config for me happened to max out my connectiong so I decided to not change anyting. The AUR is the only thing that downloads slow, but it’s not a big problem.

If you get this error, or slow mirrors, searching for those 2 topics yields a result of an Indian fellow having issues with slow mirrors and rate-mirrors happened to be a good solution stated there.

Atenciosamente, irmão acima :grin:

Thanks for the help!

I tried the command you posted here but it also timed out, so, i followed the program tip and increased(a lot) the fetch-mirror-timeout and it worked.

2 Likes

However, I have to say, have you checked if the “default config” is good for you or is slow?

You mean the default mirror list? I think the system came with a list of mirrors from France and Germany, and, like i said in the first post, it was very slow.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.