rEFInd Boot Manager Icons Strange Behaviour

So I have my esp partition mounted at /efi with grub installed along with rEFInd.
The installation , setup and everything went smoothly but when I tried to theme it , I noticed a strange behaviour .
After following the instructions for any specific theme , this theme in this case , the result instead of looking like this:

Looked a whole lot weird . Its the tools/buttons below the boot entries that behave weirdly.
The buttons were ordered in this manner:

Shutdown>Firmware/BIOS Settings/Cogwheel>Hidden Tags>About>Restart>Shutdown>Restart

As you can comprehend , the buttons repeated themselves until reaching a max limit of 7. I tried showtools argument in refind.conf to disable the tools/buttons below the boot entries but it didn’t work.

I tried to show only the shutdown and restart buttons in refind.conf using the showtools argument and it returned the same weird behaviour. Consulting rEFInd’s wiki , it seems that refind loads icons for those buttons from the icons folder by default and any other folder (if specified) and also shows all the icons for supported functionalities by default as long as the icons for the corresponding functions with that functions’ name exist.

Making sense of this , I conclude that the tools specified using the showtools arguments get shown in the specified order and then the rest of those buttons/tools shown are detected automatically from the icons directory or other (if specified) and then loaded/shown there till the max button limit is fulfilled .

Simply removing the showtools line from my chosen theme’s theme.conf which is :
showtools shutdown,hidden_tags,reboot,firmware

I get the desired result.

I also saw a tutorial on YouTube using Ubuntu 22.04 as the distro and the theme worked flawlessly out of the box there . I must consider the fact that Ubuntu 22.04 has rEFInd 0.13.2-1 whereas on Endeavour ,I use 0.14.2-1 .

The question is :
Is this an issue/unusual behaviour ? If so , how can I fix it ? If not , then is this a recently introduced autodetect-similar feature in rEFInd ? Is there any explanation of this behaviour ? If yes , then what is it ?


Is the call to your theme at the very end of refind.conf?

What is your method for installing the theme?

Yes , at the end of the .conf file and the theme was installed manually by copying the theme’s folder to /efi/EFI/refind/themes

If you link to the theme I’ll install it and see if I get the same thing. It may be an issue with the theme.

For me the theme looks pretty much as advertised:

I didn’t make any changes, it seems to work out of the box.

It might be worth deleting the rEFInd-glassy directory, re-clone the repo and try again.

I downloaded the theme using download code button from GitHub ? Could that cause it ?

Edit: Attached Picture after cloning the GitHub repo.

Hmm, I wouldn’t think so but I guess I’m not sure. I did it like this:

Change to root:


Navigate to the rEFInd themes directory:

cd /efi/EFI/refind/themes

Clone the repo:

git clone

Add the call to the theme to the end of refind.conf:

echo "include themes/rEFInd-glassy/theme.conf" >> /efi/EFI/refind/refind.conf

Reboot, take a screenshot of the boot menu screen with F10.

Please see the edit I made in my previous reply.

Do you have any other include lines in your refind.conf? From another theme, for example.

No. But I am on a HP All in one . Custom OEM bios causing issues maybe ? Also I used refind-install to install rEFInd

I’m not sure, but from what I understand it seems like rEFInd scans for those tools from the OS. Maybe Windows is exposing power off/reboot/boot to firmware options in addition to Linux?

# Default is shell,memtest,gdisk,apple_recovery,windows_recovery,mok_tool,about,hidden_tags,shutdown,reboot,firmware,fwupdate
# To completely disable scanning for all tools, provide a showtools line
# with no options.

If you set a empty showtools line, does it remove all the buttons?

If so, I think you are just getting duplicate tools scanned.

You may want to look into setting the dont_scan_tools line to take the Windows tools off of it.

# Tool binaries to be excluded from the tools line, even if the
# general class is specified in showtools. This enables trimming an
# overabundance of tools, as when you see multiple mok_tool entries
# after installing multiple Linux distributions.
# Just as with dont_scan_files, you can specify a filename alone, a
# full pathname, or a volume identifier (filesystem label, partition
# name, or partition GUID) and a full pathname.
# Default is an empty list (nothing is excluded)
#dont_scan_tools ESP2:/EFI/ubuntu/mmx64.efi,gptsync_x64.efi

An empty showtools line doesn’t accomplish anything and I still end up getting default layout of tools shown there which is better than having doubled tools.

Also , I have a separate esp partition for linux but still I will give it a shot.

Well tried it in this manner:
dont_scan_tools windows_esp_partuuid_here:/EFI/Microsoft/Boot
dont_scan_tools windows_esp_partuuid_here:/EFI/Boot

And no luck.

Do you mean you have two EFI partitions on the same disk? That is pretty unusual. Or are there two disks?

Make sure you are not using the filesystem UUID. You can get the partition UUID with sudo blkid and find the PARTUUID= value whatever partition it is.

Two esp on one disk. One made by windows , the other is for linux created during manual partitioning during install.

Pretty sure I am using the partuuid with the help of KDE partition manager.

EDIT: Tried refind on a single esp only . No luck.

After all the fuss , installed refind v13.3 manually from sourceforge and voila ! Everything works now as expected.

As it worked fine for @BluishHumility I suspect that it might be my computer showing quirks or might be an unupdated bios from HP. Could also be refind causing issues with my specific device. Nevertheless, the issue is now resolved.

Again , sincere thanks @BluishHumility .

EDIT: After testing , it seems that 0.14.1 is the latest working refind version for me.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.