ReferenceError: chrome is not defined

i noticed yesterday that i get this error

ReferenceError: chrome is not defined

when i go at

I have firefox developer edition, chrome-gnome-shell and the firefox addon installed.
I saw the same issue on an other PC with regular firefox.

Does anyone else have the same issue?

Try rebuilding the chrome-gnome-shell. It’s reported as a problem it’s possibly one of these extensions.

Thank you for the fast reply. I should have mentioned that i already tried it. Also, the second PC that i saw this issue has a fresh install of Endeavour. I tried to install all the bits needed to install extensions. I see in the thread you mention that the issue is not resolved. I see now that i cannot install anything from the Extension Manager also.
You do not have the same issue?

This is not exactly a solution to your issue but a way to install the extensions you want in the meantime while you are looking for a solution.

It is done manually as described in the article linked to below:

Once installed in this way, they would work as expected and you will be notified as well from the Extensions app when there is an update to them. You don’t need to do it manually then again. Just a simple log out and log in will do.

1 Like

I use a few specific extensions in Firefox and i have never had any issues. I don’t typically use Gnome. Are Gnome extensions the same as an extension in Firefox? I really haven’t given it a thought. As far as Gnome goes and Firefox i would be using the extensions that i know work. It’s like the packages in the AUR. Unless you can trust them then it’s just a gamble as to whether they work properly or not in my opinion.

You need this Firefox addon


to be able to install extensions to the GNOME shell from from Firefox.

It’s been hit and miss for me before, so I just install them manually as described in the article I linked to.

I know that there is a “relatively” new app, Extension Manager, but doing it the way I am doing works fine for me.

Thanks! Manual installation it is then! I thought that i would not get the update notifications from the app that way. The auto install always worked fine for me, until yesterday. I will try it tomorrow morning and i will report back if i have any issues.

1 Like

They are kind like browser extensions, but a connector is needed that handles the installation.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.