Redshift not working with i3wm


I was just looking around to figure out how to enable something like night shift for my display. After looking around for a bit I found redshift which works great when I run this command in my terminal:

redshift -l 52.1326:5.2913

Since I wanted redshift to start whenever I’m starting my pc and I’m using i3 I put it into the i3 config like this:

exec --no-startup-id redshift -l 52.1326:5.2913

I saved the file and refreshed the config and I didn’t work so I restarted my pc, it didn’t work again. I checked the i3 config and the line is still in there so it should’ve worked.

So I ran

redshift -l 52.1326:5.2913

again and the display dims again but now it’s also flickering every few seconds (irregularly).

Any ideas how I can fix this or generally speaking enable redshift (or any alternatives?) for endeavour with i3wm?

not sure it’s a WM thing (yet). the thing with redshift is you need to amend it’s startup .conf file with those coordinates. I’ve had that flickering.
I’ve never had much luck appending the conf file [the internets all say must append conf file with coordinates etc]…

so I did find a workaround.
I used to run this command in autostart (budgie) every time it booted: redshift -O 4000.
the 4000 is just my preference of brightness.
later I got rid of the script so I could just adjust as needed during the day with a fast terminal command.

you could see if the -O thing gets rid of your flickering. good luck.

1 Like

There is quite some info here:

1 Like

I’ve never used a redshift config.file, preferring to put my config all on a command line in a small shell file.

I’d suggest the OP try just two decimals for their lat/long coordinates.

redshift -l 52.13:5.29

ensure you don’t have any stray redshift processess running, as this might cause the flashing.

ps axu | grep redshift

then kill any errant processes:

kill NNNN

where NNNN is the process number from the process stack printout

1 Like

I solved it now like this:

  1. Created a~/.config/redshift/redshift.conf (modified version of this example from the GitHub page)
  2. Used redshift-gtk instead (don’t know how much that has helped but I like to have the icon)
  3. In my i3 config: exec --no-startup-id redshift-gtk

That seems to work now. Thanks for all the replies!


you did the tried and true internet method (I could not make that happen) so congrats! I made a ~/.config/redshift/redshift.conf file, alternated between redshift and redshift-gtk, which spawned more conf files…then I had it set to autostart so that changed everything and nothing worked and flickering started and I really made a mess of it. Enter redshift -O XXXX.

We each solved it a different way, that’s what I love about linux. Good job @Trichter !

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.