Reboot not possible

Every time I want to reboot my system, I get stuck at the following screen:

The message is always the same, and it always gets stuck at the same spot.

When I press on “power off” then it shuts down just fine.

Looks like some device is not being taken down correctly. You should be able to find more information in the journal. You can use journalctl -b -1 to look at the journal for the previous ("-1st") boot.

Ran that command, came across the same message as in my picture, but I have no idea what I should be looking for.

Find the processes with process numbers reported in the message (447, 480) in case there is some malformed udev rule, or similar.
Also, disable wachdog(s), from Archwiki instructions.

nowatchdog parameter was already in my boot loader configuration, so that would mean that it was disabled.
I also tried to blacklist following module iTCO_wdt.
Those processes 447 and 480 and systemd-udevd processes. I don’t know what should I do about them.

With every boot, process ID of those processes changes.

You should review your existing/custom(???) rules to see errors. Have you added/modified udev rules lately? (due to another issue )

I haven’t modified anything regarding udev. Therefore I shouldn’t have any custom rules (I don’t even know know is that supposed to mean).

Did you try running this command:

sudo systemctl restart systemd-udevd

before a shutdown and reboot yet?

Also, take a look here.

1 Like

I have not. Will try it out as soon as I come home. Thanks for the suggestion.
Shutdown seems to work every time. Reboot on the other hand never works :slight_smile:

This is a totally wrong conclusion.

Even if it was true, don’t you find these two statements contradict each other?

Ask your System Administrator about udev rules. He should know. Alternatively, read Archwiki and man pages.
Then check your existing udev rules in all possible paths and review them for ownership and correctness.

By those statements I meant that I don’t even know what udevd meant, therefore I wouldn’t modify anything that has to do with it. Since I haven’t modified anything there, there shouldn’t be anything “custom” in there.

1 Like

The warning ‘watchdog didn’t stop’ occurs to me on most all installations. So no worry about that one. It seems a recurring, upstream Arch Linux issue, that does not hinder the reboot process itself.

I have these messages too, three in a row and only while rebooting.

…getting there yet?

I have read that online as well, however my issue seems to be waiting for process; 447 (systemd-udevd), 480 (systemd-udevd)

I get those messages only during reboot, and reboot never succeeds :frowning:

I also don’t have some weird or complicated setup that would justify it not working out of the box.
But since I am a Linux noob, I could be wrong 100%

Was about to do it. Will reply once I did those steps.

Check the journal for that service and you might know what it is doing.

journalctl -fu systemd-udevd

1 Like

Alright, so I tried running sudo systemctl restart systemd-udevd before reboot, and it rebooted successfully.

Then I tried rebooting again without using that command, and it rebooted successfully.

The third time I tried to reboot, it didn’t reboot successfully, and I got the same message (systemd-udevd).

I ran journalctl -fu systemd-udevd and the output is the following:

Does that point towards one of my USB devices causing that issue?

Two of your devices are being named.

I’d try a boot and subsequent reboot, AFTER unplugging them, just to find out.