Reboot into firmware interface problem

So, After installing EndeavourOS, I decided to increase my swap space, I’m a newbie and I think I did something wrong. when increasing the swap space and restarting it only showed me one option called Reboot into firmware interface. Keep in mind I’m using XFCE and systemd-boot. Can anyone help?

Some more details about what changes you exactly made and also about your system would surely helps those able to help you to have something to go by.

How did you increase the swap space? What commands, etc?
What other system files did you modify? And in what way?
What file system are you using?

Also, please have a look at the article linked to here below and provide some “hardinfo”, logs, etc.

Hopefully, this will give forum members some more clue as to what might be going on with your system.

Welcome to EnOS’ community and good luck!

:enos_flag: :wave:t5:

Welcome to the purple side of the internet! :smile:

Logs are always essential, as @pebcak already asked for.

If the only change you did was resize the swap partition, the problem can be the swap setting in file /etc/fstab. It should be changed to correspond the new partition uuid.
You do this by booting with the USB installer stick and using e.g. a terminal and the nano editor:

lsblk -f    # shows partition info needed for the fix
sudo nano /etc/stab

welcome @len :enos:
as i can see you are not able to boot the EndeavourOS install so you can also hardly provide logs in this state…
But if you have still the installer image at hand you can boot installer usb (ISO) and arch-chroot into the installed system:
From there you can show logs and systeminfo

Hi All,

I’ve managed to get myself into the same predicament.

I’ve tried bootctl install and bootctl update from within arch-chroot, but that hasn’t helped.

I’m not sure how to fix my loader.conf, if that’s the issue.

No system changes, I just had a hard freeze and when it came back up, “Reboot into firmware interface” was the only option I could get.

Here is my inxi -FAZ:

Here’s a listing of my /efi partition, the contents of my loader.conf, and /etc/fstab:

Here’s the output of bootctl list:

Any help much appreciated :smiley:

Also, here’s a little more in-depth info from inxi:
(output of inxi -Fxxxza --no-host)

Fixed my own problem by running pacman -S dracut kernel-install-for-dracut linux linux-api-headers linux-firmware linux-firmware-whence util-linux from the arch-chroot

I don’t know how many of those were needed, but it got the job done! XD

1 Like

Thanks, this fixed my problem, all those packages were up to date on my system but something in the reinstall process restored my boot options. My problem started after installing package updates presented by the system.

Grtz Marco

1 Like

Cool beans! I wish I knew which command to run to fix the problem directly, but yeah, somewhere in one of those packages install scripts is the solution :wink: