Reboot hangs with black screen and blinking cursor

I have recently got a Dell XPS 15 laptop with a new installation on it.
I’m having a problem when rebooting (I just run ‘reboot’ in a terminal), where the desktop (XFCE in my case) is shut down but then the process stops at a black screen with only a blinking underscore cursor.

I’ve been googling around a bit to find a solution, so far what I’ve tried is to

  • Disable lvm2-monitor.service (though this seemed to get automatically re-enabled somehow)
  • Install and enable rngd

Here are my journalctl logs from the start of the session until the hanging reboot:

Here is the very end of the log:

Jun 19 16:21:00 arch systemd[1]: Finished Reboot.
Jun 19 16:21:00 arch systemd[1]: Reached target Reboot.
Jun 19 16:21:00 arch systemd[1]: Shutting down.
Jun 19 16:21:00 arch audit: BPF prog-id=16 op=UNLOAD
Jun 19 16:21:00 arch audit: BPF prog-id=15 op=UNLOAD
Jun 19 16:21:00 arch audit: BPF prog-id=14 op=UNLOAD
Jun 19 16:21:00 arch audit: BPF prog-id=13 op=UNLOAD
Jun 19 16:21:00 arch audit: BPF prog-id=12 op=UNLOAD
Jun 19 16:21:00 arch audit: BPF prog-id=11 op=UNLOAD
Jun 19 16:21:01 arch systemd-shutdown[1]: Syncing filesystems and block devices.
Jun 19 16:21:01 arch systemd-journald[360]: Journal stopped

As far as I can tell there aren’t any errors related to the reboot, but I’m also not sure what the end of the log here should look like when actually successful.


Could you post the link for the following.

inxi -Fxxxz --no-host | eos-sendlog

Here it is:

Thanks for the link. I see you have an Nvidia GTX 1650 Ti Mobile and is currently running the open source driver Nouveau. I also don’t see any real obvious boot errors. You may want to try a kernel parameter added to the default grub command line on boot and see if that makes any difference.

acpi_osi=‘Windows 2020’



I tried adding a kernel parameter as you suggested, but it makes no difference :confused:

Why don’t you also try the lightdm check graphic under troubleshooting.

The docs there seem to mention only booting, I have no problems during startup, lightdm starts up perfectly every time. Would that setting affect shutdown as well?

It shouldn’t i just sometimes don’t know if i understand the problem as explained. I thought maybe it was booting up and hanging at the loading of the desktop. But your saying it’s hanging on shutdown before it restarts?

I think you are going to have to look at some logs, dmesg etc to try to figure it out what is causing it to hang and at where exactly in the reboot stage.

Exactly, it always hangs on shutdown/reboot, though never on boot up to the DM.
Boot from POST until logged into desktop has worked perfectly every time so far.

How can I get the relevant dmesg logs for the previous boot when the hang occurred?

I just wanted to ask Did you update grub when you tried the kernel parameter? After adding acpi=force to the default grub command line. Or the other kernel parameter acpi=“Windows 2020”

sudo grub-mkconfig -o /boot/grub/grub.cfg

Yeah I did that. At least for the windows opttion, I might have to try again for acpi=force

You could also try removing “quiet” from the default grub command line and run the update grub and shutdown and see if you can see any messages that show where it stops? Then you can change it back after.

Also have you looked at any boot logs? There is the logs for troubleshooting tool on the welcome screen for creating some of those logs.

Maybe post the following log link and I’ll also look at it and see if anything stands out.

journalctl -e -b-1 | eos-sendlog