Realtek network card 10ec:8852 not detected/working

I am currently trying to install EndeavourOS on my lenovo laptop (I also have it on the desktop i am currently using)

However I wanted to do a online install and install it with KDE but then I realized I wasn’t connected to the wifi but I also can’t connect to it because XFCE says “No network devices available” I checked the Inxi log and saw that the network Device doesnt have a driver

Device-1 Realtek vendor: Lenovo driver: N/A port:2000 chip-ID: 10ec:8852

I also tried plugging in a usb for a another wifi connection which at least detected the wifi and also connected to it but I always get instantly disconnected.

Should I just do an offline install or is there a way I can get the wifi to work?

As a “workaround”, you might perhaps be able to usb-tether your phone’s internet connection to do an online install.

1 Like

right! I forgot about this give me a second I will try it

1 Like

This probably needs the rtw89-dkms-git driver from the AUR. I think support is also included in kernel 5.17.


I will see once I get my system installed currently Im trying usb-tethering (which I completely forgot) how pebcak suggested

But currently the installation is always failing because it cannot shrink the partition of the ssd (

Please show the partitioning of the disks:

lsblk -fm
sudo fdisk -l

and tell which partition are you going to use for linux.

I “fixed” it
I was going into my windows to then shrink the partition there and then booted up the live usb again and installed the system again I hope it works now

Should work. Great that you got it installed!

I can always rely on you guys :sweat_smile: not proud of that but I hope that will change in the future
so thank you!

@jonathon i think is correct that the chip will have support in the 5.17 kernel. I think this Realtek is WiFi 6 AX

So I should Install that package when I have a working system, right?

Yes for now and should work as @jonathon suggested. Then when the 5.17 kernel is out you may not need the package as it should be supported in the new kernel version hopefully.

it works!
I hope 5.17 will fix it for all users but as long as there is some way to do it im fine with that.
anyway I installed kde I connected to my wifi so thank you!

1 Like

It shouldn’t be any problem either way as long as it works. :wink:

That is true :smiley:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.