“Read only - Command exited”


I’m using Gnome DE with extension Arch Linux Updates Indicator. It works, but there is one problem. When I press the Update now button now and after the update is completed, in theory, when I press the enter button after all this, the terminal (kgx) should close. But instead of the terminal closing when the enter button is pressed, it does not close and gives the following message to the terminal window in bottom with blue background: Read only - Command exited. And further on pressing the enter button, the terminal does not close, I can close it only by clicking on the cross or by pressing ctrl+shift+w.

Content to check for package updates: /bin/sh -c "(/usr/bin/checkupdates; /usr/bin/yay -Qqu --color never | sed 's/Get .*//') | sort -u - t' '-k1,1"
Content to update packages: kgx -- sh -c "yay ; echo Done - Press enter to exit; read"

Even if I remove read in the content for update packages, this does not solve the problem.

Personally I use the terminal for these things, since updates are happening almost all the time. If you don’t want to use terminal for this, then don’t read further. :wink:

One simple command takes care of updates:


and the same applies to command


But if you don’t want to write the password and a long command every time, here’s an alias that checks updates and performs the update only if there are some available:

alias update='checkupdates || paru -Qua && paru'

Unfortunately the alias won’t work correctly with yay.


This seems like an utterly pointless alias.

What’s the purpose of checking whether there are updates available if your intention is to update your system? The update itself checks for updates anyway. :rofl:

The only time one should check if there are updates available is when one might not want to update.

Usually, that’s the case when one is waiting for some specific package to be available for update before updating the entire system (e.g. not wanting to update the kernel if there is no NoVidea driver update available, as that will boot to black screen). That’s the only reasonable time one should check whether there are updates available.

If you’re going to update regardless, it’s pointless to check if there are updates available before updating. You’re just wasting mirror bandwidth (and your time).

So let me fix your alias:

alias update=paru

BTW, this works with yay, too. :rofl:


It is an issue with Gnome Console(kjx). That application is exceptionally feature free and does not have an option to close when the running command ends when launched with a command.

The only real solution is to use a different terminal.


Looks like you missed the reasoning:

if you don’t want to write the password and a long command every time

And, please note, I was not recommending this practice. :wink:

That’s one of the things UpdateInTerminal will check and warns for you and offers to stop the update process in case of missing nvidia update.
So, BTW, this works with UpdateInTerminal, too. :rofl:

Anyway, all of this is offtopic…

1 Like

Who’s talking about UpdateInTerminal? That’s just cat abuse :crying_cat_face:

I’m talking about the alias where you first check for updates and then automatically update. That’s pointless, wasting mirror server bandwidth.

1 Like