Razer peripherals

Hey all!

Just got a new Razer mouse. Works great out of the box, as did the previous one. (They make great mice!) However I would like to have the option to control the chroma lighting. Mainly to turn off the lighting, or maybe set it to a solid colour. I’m a minimalist.

Has anybody gotten openrazer-meta to work? Does it work like it should?

Side question: has anybody gotten their wireless mouse to work with evdev passthrough?


Turns out wireless mouse works just fine with evdev. Initially had some trouble, cause I wasn’t using the “event-mouse”. Fixed that and evdev works perfectly.

Got openrazer installed, but it won’t start. I guess that’s because Viper Ultimate isn’t supported yet.

Viper Ultimate is supposed to be supported now in openrazer, but whenever I launch polychromatic, my device is still not recognised. Went through the trouble shooting pages, but couldn’t get it to work.

I went with polychromatic as a gui for my razer mouse.

Are you using the same mouse? How did you get it to work with the software?

I use Razer keyboards and mice as well. Setting them up in Linux wastes a lot of time but there is a shortcut “if you have Windows on one of your computers”.
Simply, set up the mouse on a Windows machine (with the Razer bloat software installed), then unplug it and move it to any Linux computer.
All of my peripherals remember the color setting during reboots.

have you done:

Please run the command 'sudo gpasswd -a $USER plugdev' and then reboot!
systemctl --user enable --now openrazer-daemon.service

Also try the troubleshooting at:

Going to be honest, I got it working fine on my last install of Endeavour but I’m running into the same issue of my mouse not being recognised this time around. Mine is a Razer Mamba, non wireless and should be supported.

There’s no instruction to do “systemctl --user enable --now openrazer-daemon.service”. I have not done that.

Trying to do that command gives an error: No such file or directory.

1 Like

Not a solution. I want to be able to control the lights without windows.

You will need a frontend like polychromatic to control the the daemon. There are some other apps listed at the github page.(scroll all the way down)

Upgraded mine to git versions and now it’s working, the non-git version didn’t have support for my mouse.

https://github.com/openrazer/openrazer#device-support gives a list of devices supported, pay attention to USB VID:PID and compare with the USB devices you have installed by running: sudo lsusb

You can check the supported devices for the version you currently have installed by opening:


You’d think that the higher the version the better the support. :smiley: I’ll give git versions a try. They were 2.6.x, the official version was 2.7.0-1.

Edit: installed the 2.6 version. No luck. :frowning:

Still getting this error with the git version.

There’s a 2.8 version!!! However that’s not in AUR. How do you install it?

have you checked if the device is supported and is recognised?

Mine just updated to 2.80 via yay though I have saved the developer flags.

You should upgrade all the components to the git version:

openrazer-daemon-git 2.8.0.r0.g95e7307d-1
openrazer-driver-dkms-git 2.8.0.r0.g95e7307d-1
openrazer-meta-git 2.8.0.r0.g95e7307d-1

The device is supported, but doesn’t work with the aur-git version 2.6 or the aur version 2.7.

I have no idea what I did… maybe I just refreshed the pamac databases, but the 2.8 (non git) version appeared in there. I installed those and added my user to the dev group again. Rebooted. Restarted the daemon and now it works.

Managed to set the mouse RGB dim static color, but no effect on the hub/dock. I guess it’s not supported yet. But I think I can do that on my windows VM.