Random System Freeze

Are you still having the system freeze problem? What is your hardware? Also you checked for bios updates?
inxi -Fxxc0

Not untill now.
My bios already had been flashed a couple of months ago with the latest firmware.

I’ve removed xf86-video-intel and xf86-video-vesa.



$ inxi -Fxxc0
System:
  Host: richard-pc Kernel: 5.4.12-arch1-1 x86_64 bits: 64 compiler: gcc 
  v: 9.2.0 Desktop: Xfce 4.14.2 tk: Gtk 3.24.13 wm: xfwm4 dm: LightDM 
  Distro: EndeavourOS 
Machine:
  Type: Portable System: Dell product: Inspiron 15-3552 v: 4.4.0 
  serial: <root required> Chassis: type: 8 serial: <root required> 
  Mobo: Dell model: ������ v: ��� serial: <root required> 
  UEFI [Legacy]: Dell v: 4.4.0 date: 03/06/2018 
Battery:
  ID-1: BAT0 charge: 29.1 Wh condition: 30.2/37.3 Wh (81%) volts: 15.9/14.8 
  model: PANASONIC DELL 78V9D63 serial:   187 status: Discharging 
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse 
  serial: 4055-5e-3d-da-cf charge: 55% (should be ignored) 
  status: Discharging 
CPU:
  Topology: Dual Core model: Intel Celeron N3050 bits: 64 type: MCP 
  arch: Airmont rev: 3 L2 cache: 1024 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 6402 
  Speed: 1433 MHz min/max: 480/2160 MHz Core speeds (MHz): 1: 1433 2: 488 
Graphics:
  Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx 
  Integrated Graphics 
  vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:22b1 
  Display: x11 server: X.Org 1.20.7 driver: modesetting unloaded: fbdev 
  alternate: intel,vesa resolution: 1366x768~60Hz 
  Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:
  Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series 
  High Definition Audio 
  vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  chip ID: 8086:2284 
  Sound Server: ALSA v: k5.4.12-arch1-1 
Network:
  Device-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter 
  vendor: Dell driver: ath9k v: kernel port: f040 bus ID: 01:00.0 
  chip ID: 168c:0036 
  IF: wlan0 state: up mac: b0:c0:90:40:74:45 
  Device-2: Qualcomm Atheros type: USB driver: btusb bus ID: 1-2.1:7 
  chip ID: 0cf3:e005 
Drives:
  Local Storage: total: 119.24 GiB used: 26.11 GiB (21.9%) 
  ID-1: /dev/sda vendor: Crucial model: CT128MX100SSD1 size: 119.24 GiB 
  speed: 6.0 Gb/s serial: 14270C890760 
Partition:
  ID-1: / size: 108.73 GiB used: 26.11 GiB (24.0%) fs: ext4 dev: /dev/sda1 
  ID-2: swap-1 size: 8.27 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2 
Sensors:
  System Temperatures: cpu: 31.0 C mobo: 32.0 C 
  Fan Speeds (RPM): cpu: 0 
Info:
  Processes: 151 Uptime: 8m Memory: 3.76 GiB used: 1.18 GiB (31.3%) 
  Init: systemd v: 244 Compilers: gcc: 9.2.0 Shell: bash v: 5.0.11 
  running in: xfce4-terminal inxi: 3.0.37

I’m following this thread: https://bbs.archlinux.org/viewtopic.php?id=250765&p=4

Edit: I can trigger a freeze when I’m running a video with VLC…

Okay so I left my Laptop running on LTS for some time and it froze again. I am not 100% sure if its this issue, because it was a idle blackscreen and no sound was playing. But I assume its this issue, since there wasnt any reaction possible and I had to cut the power again.

@Tiedemann
As requested here the full journal(I left out some NetworkManager lines):
https://pastebin.com/BCGJfBRm

@axt
Thanks for the suggestion, I will look into it.

lemon
The issue occurred quite frequently while playing media or vlc also for me. More often than being in an idle state.


I appreciate the feedback and suggestions and hope to fix it, since I originally planned to move from Win10 to EndeavourOS on my main setup.

@Lemon Have you tried this kernel parameter?

intel_idle.max_cstate=1

as on the pastebin i saw also AMD pieces and parts… made me curius…

what is pacman -Qs ucode ? just feedack idk what happend…

had once someone had two ucodes installed and had some little freezes… two ucode on iso is ok but not on a installed…but just what it looks it looks also parts of amd so there is something, but thats why i wanna see which ucode is installed…

Def worth a shot! @Salva

The baytrail bug only seems to have a workaround and not a fix though so ending up with using more power all the time.

https://bugzilla.kernel.org/show_bug.cgi?id=109051

$ pacman -Qs ucode
local/intel-ucode 20191115-3
    Microcode update files for Intel CPUs

your case is different :slight_smile: pastebin was from @Salva i believe :slight_smile:

@Salva
Not sure if this might work.

https://bbs.archlinux.org/viewtopic.php?id=248121

I mixed up the different system specs in this thread. Separate threads please when not having the same system specs! :stuck_out_tongue:

1 Like

Would I add this to /etc/default/grub or /boot/grub/grubcfg?

Edit: Doesn’t really matter, I quess…

* To make the change persistent after reboot, you *could* manually edit `/boot/grub/grub.cfg` with the exact line from above, but the best practice is to:

Edit `/etc/default/grub` and append your kernel options between the quotes in the `GRUB_CMDLINE_LINUX_DEFAULT` line:

Wrong. This is to be entered in “/etc/default/grub”, e.g.:

GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi=Linux acpi_backlight=vendor acpi=copy_dsdt intel_iommu=igfx_off"

After each change grub must be updated with:

sudo mkinitcpio -p linux

1 Like

Okay, but the Arch wiki says that I could change grub.cfg too.
That is what I have done and I haven’t had a freeze so far.

# grub-mkconfig -o /boot/grub/grub.cfg

Well, I have already described the setting of uxa instead of sna (Ger) in 2016. But it’s not about freezes, but about disappeared mouse pointers after standby and the like.

Of course one can test it, but eventually uxa will not be supported anymore.

Or one just uses the modesetting driver instead of the intel driver.

@judd, hint: The forum software interprets a “#” as bold and higher font size.

If you want to write “#” as a rootshell character, you have to put it in preformatted text (ctrl+shift+c), e.g.:

# mkinitcpio -p linux

1 Like

Fixed, thank you !

Hello @Lemon
So are you still running the current kernel? What did you end up trying for the freezing?

Hi Rick, I added the parameter you suggested and it looked like it was working.
But, after six hours or so the kernel panicked again a few minutes ago…

But, after looking into the grubcfg file I see that I added this parameter at the wrong place. :upside_down_face:
I added it in the fallback line, I’ve changed it now.

When you say the kernel panicked do you mean you got a kernel panic on boot? What exactly has been happening? Just freezing when using the computer? Did you undo the changes you made then? You did say you removed xf86-video-intel and xf86-video-vesa? Is using the intel driver worse or the same?

Have you tried using the intel driver with one of these changes to the xorg configuration here.
/etc/X11/xorg.conf.d/20-intel.conf

Option “NoAccel” “True”

OR comment out this one.

Option “DRI” “False”