Radeon Graphics Card shows 0% Usage

While in the past i ignored it, i have been looking into why my GPU shows 0% and no readings inside the System Monitor.

Most reports i found were on NVIDIA, which clearly did/would not fix my issue

using lspci -k | grep -A 3 -E “(VGA|3D)” mentioned on https://wiki.archlinux.org/title/AMDGPU:
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Barts PRO [Radeon HD 6850]
Subsystem: Micro-Star International Co., Ltd. [MSI] Device 2441
Kernel driver in use: radeon
Kernel modules: radeon, amdgpu
This is evidently not as the site says it should be, as it uses radeon rather than amdgpu, but one evening i had a fiddle (a while ago, i cant recall what i did, everything is stable though), and changed the driver in use to as above
However, previously it was “correct” and used amdgpu, still without any reading

Any ideas how i can fix this so i have a valid reading?
PS: using Plasma

This is correct as far as my knowledge. It should be loading radeon module as this card is not a Southern Islands. It is not the GCN archtecture which are a select few 7xxxx series cards and newer. Your card is Terascale 2 and is too old for amdgpu.

From The Arch wiki:
Depending on the card you have, find the right driver in Xorg#AMD. At the moment there is Xorg radeon driver support for Southern Islands (SI) through Arctic Islands (AI) cards. AMD has no plans to support pre-GCN GPUs. Owners of unsupported GPUs may use the open source radeon driver.


Are you running anything on it?

For instance, I launch items with discreet or integrated GPU.

This should be available via switcheroo-control.service. Depending how old your install is, you may or may not have ever had it setup (I haven’t tried recently, but I assume it’s installed by default now, although I am not sure.

**I’m running AMD 5800H/Radeon 6600M GPU

as far as i’m aware it is the only GPU i have, so i can’t see why things shouldn’t be running on it. plus i don’t get any temperature reading at all, whilst i would if i was on Windows 7 (via HWINFO)

On a side note, inside the Info centre, then into Graphics, OpenGL (GLX) is fine, Vulkan crashes when generating page content (iirc my GPU doesn’t support Vulkan anyway…) but OpenGL (EGL) seems to have an error, paste here: https://pastebin.com/prxTrX6X , could this be a factor?

Cheers for clarification!

This is the info for your era of graphics card. Your card would be Terra Scale 2 as posted above.



As far as i know your card should be using radeon kernel module and xorg drivers one or both of these.
xf86-video-amdgpu & or xf86-video-ati.

All the information is in the 3 links above. It may not be showing information because it isn’t reading the hardware properly. :man_shrugging:

I’m not sure whether your card works with vulkan-radeon and lib32-vulkan-radeon. You could try installing those packages and see if the info is different and whether it still crashes.

I have the suggested drivers as stated in the documentation, nothing appears to of changed regarding the drivers in use. I do have the 2 vulkan-radeon drivers you mentioned, the info is the same and it still crashes.

I’m fairly certain the OpenGL crash is the issue here, or at least part of it,and regardless will be causing some form of issue,
radeon: Failed to get PCI ID, error number -13
This was the error, with the full log in my previous post, any knowledge on solutions for this?
Sorry to ask but I’ve looked on at least 20 webpages, but most are either for ubuntu, another area completely, or on some arch forum from 2009 with a “fix is here” link that is invalid anyway. Any modern /up to date solutions known?

and cheers!

Wait, so do OpenGL applications work, but the usage is not shown?
What happens when you run glxgears? Do you get the same errors?
Have you tried to check the usage with radeontop?

Those are just wrappers for glxinfo, vulkaninfo and eglinfo commands. Can you provide the output of

glxinfo -B


EGL_PLATFORM=x11 eglinfo

You don’t have thse installed do you?

amdvlk and lib32-amdvlk.

glxgears runs fine/smoothly/no errors , i can’t think of an application specifically using OpenGL which i have on this PC
just updated/tried radeontop, it shows the usage fine actually :thinking:
https://pastebin.com/JcYbcavJ - glxinfo -B Results
https://pastebin.com/MRFCwx0s - EGL_PLATFORM=x11 eglinfo Results

amdvlk is installed, however lib32-amdvlk appears not to be.

Everything is OK, you can safely ignore Failed to get PCI ID, error number -13 messages, its just the driver trying different rendering nodes on older hardware. You have direct and accelerated rendering, and opengl/3d is working fine. You also confirmed that radeontop is working so the issue is with the system monitor program. You mentioned you are using KDE, so I guess you are using KSysGuard System Monitor. Well, it will not show the usage there because the driver is not exposing its GPU usage properties to kernel’s interface.

How do I know this? I’ve finally managed to find my old Radeon HD 7850 and test it :smile: Its the same generation (Southern Islands), does not support vulkan and I am getting same PCI errors for eglinfo

My inxi -Ga

  Device-1: Intel IvyBridge GT2 [HD Graphics 4000] vendor: Gigabyte
    driver: i915 v: kernel arch: Gen-7 process: Intel 22nm built: 2012-13 ports:
    active: none empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2, VGA-1 bus-ID: 00:02.0
    chip-ID: 8086:0162 class-ID: 0380
  Device-2: AMD Pitcairn PRO [Radeon HD 7850 / R7 265 R9 270 1024SP]
    vendor: Micro-Star MSI driver: radeon v: kernel alternate: amdgpu
    arch: GCN-1 code: Southern Islands process: TSMC 28nm built: 2011-20 pcie:
    gen: 3 speed: 8 GT/s lanes: 16 ports: active: HDMI-A-3
    empty: DP-3,DP-4,DVI-I-1 bus-ID: 01:00.0 chip-ID: 1002:6819 class-ID: 0300
    temp: 36.0 C
  Display: x11 server: X.Org v: 21.1.6 compositor: kwin_x11 driver: X:
    loaded: modesetting,radeon alternate: fbdev,intel,vesa dri: radeonsi,crocus
    gpu: radeon display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 676x380mm (26.61x14.96")
    s-diag: 775mm (30.53")
  Monitor-1: HDMI-A-3 mapped: HDMI-2 model: LG (GoldStar) Ultra HD
    serial: 146047 built: 2018 res: 2560x1440 hz: 60 dpi: 108 gamma: 1.2
    size: 600x340mm (23.62x13.39") diag: 690mm (27.2") ratio: 16:9 modes:
    max: 3840x2160 min: 640x480
  API: OpenGL v: 4.5 Mesa 22.3.3 renderer: PITCAIRN ( LLVM 15.0.7 DRM 2.50
    6.1.8-arch1-1) direct render: Yes

My glxinfo -B

name of display: :0
display: :0  screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: AMD (0x1002)
    Device: PITCAIRN (, LLVM 15.0.7, DRM 2.50, 6.1.8-arch1-1) (0x6819)
    Version: 22.3.3
    Accelerated: yes
    Video memory: 2048MB
    Unified memory: no
    Preferred profile: core (0x1)
    Max core profile version: 4.5
    Max compat profile version: 4.5
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.2
Memory info (GL_ATI_meminfo):
    VBO free memory - total: 1367 MB, largest block: 1367 MB
    VBO free aux. memory - total: 1994 MB, largest block: 1994 MB
    Texture free memory - total: 1367 MB, largest block: 1367 MB
    Texture free aux. memory - total: 1994 MB, largest block: 1994 MB
    Renderbuffer free memory - total: 1367 MB, largest block: 1367 MB
    Renderbuffer free aux. memory - total: 1994 MB, largest block: 1994 MB
Memory info (GL_NVX_gpu_memory_info):
    Dedicated video memory: 2048 MB
    Total available memory: 4091 MB
    Currently available dedicated video memory: 1367 MB
OpenGL vendor string: AMD
OpenGL renderer string: PITCAIRN (, LLVM 15.0.7, DRM 2.50, 6.1.8-arch1-1)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 22.3.3
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 4.5 (Compatibility Profile) Mesa 22.3.3
OpenGL shading language version string: 4.50
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile

OpenGL ES profile version string: OpenGL ES 3.2 Mesa 22.3.3
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20

The only thing exposed to hwmon via lm_sensors interface is the GPU temperature (rerun sensors-detect and answer yes everywhere if you don’t see it)

But not all is lost if you want GUI for monitoring the GPU. There is a cool app in AUR for displaying all kinds of info for cards using radeon driver (you can also set the power profiles and fan curve) called radeon-profile. It works good with my card and is showing the same usage as radeontop

To install it run

yay -S radeon-profile-git radeon-profile-daemon-git
sudo systemctl enable --now radeon-profile-daemon.service
1 Like