Quick tip for Conky with Wayland

I just started using Wayland as my “Daily Driver” (nVidia driver kept me away from trying it for quite a while) & I noticed that my Conky flickered on a regular basis…So I looked at the update_interval—it was set to (1) & playing with it–stopped flickering at (.75) —that will eat up a few more CPU cycles running that fast, but I would rather have a flicker-free conky…

Did you try double_buffer = true, or is that an Xorg-specific setting?

double_buffer = true is not making a difference…The only thing that stopped it was the change to update_interval. Have not seen one flicker after the change.

I would “guess” that double_buffer is just xorg. I’ve been making conkys for close to 15 years now & had not seen flicker like that before trying Wayland.