Questions about nvidia-inst / NVIDIA drivers / no image via DisplayPort


I installed EndeavourOS about a year ago. In terms of NVIDIA drivers I did not do much except for selecting proprietary NVIDIA drivers when installing the OS…

So far everything worked until I bought a new 1440p / 165Hz monitor (MSI MAG274QRF-QD) which I connect via DisplayPort (my old one was connected via DVI).

If I turn on the monitor after I turn on my computer I won’t get a signal - until I blindly type in my password, pray that it’s correct and manage to log into KDE. Then I get an imagen (my KDE desktop).

If I turn on my monitor before turning on my PC everything works and I see the BIOS boot screen, then GRUB2 menu and then my KDE login screen.

This only happens with DisplayPort. When I connect the monitor via HDMI it does not matter at which point I the monitor on. I get an image every time.

I already used the NVIDIA Graphics Firmware Update Tool for DisplayPort 1.3 and 1.4 Displays to update the firmware of my NVIDIA GTX 1060 6GB

So I wanted to update / reinstall everything NVIDIA related and fell down a rabbit hole.
I learned about nvidia-inst and did some more research.

Currently I have the following packages installed:

local/lib32-nvidia-utils 510.60.02-1
    NVIDIA drivers utilities (32-bit)
local/libvdpau 1.5-1
    Nvidia VDPAU library
local/libxnvctrl 510.60.02-1
    NVIDIA NV-CONTROL X extension
local/nvidia-dkms 510.60.02-1
    NVIDIA drivers - module sources
local/nvidia-installer-common 1.0-1
    Common scripts for nvidia-installer-dkms and nvidia-inst
local/nvidia-installer-db 2.5.8-1
    Database for the script to setup nvidia drivers in EndeavourOS
local/nvidia-installer-dkms 3.4-1
    Script to setup nvidia drivers (dkms version) in EndeavourOS
local/nvidia-settings 510.60.02-1
    Tool for configuring the NVIDIA graphics driver
local/nvidia-utils 510.60.02-1
    NVIDIA drivers utilities

When I install nvidia-inst and run nvidia-inst -t I get the following output:

[android@endeavour ~]$ nvidia-inst -t
2022-04-11 20:45:45: Info: Running: nvidia-inst v1.0.3-1
2022-04-11 20:45:45: Info: Command line: nvidia-inst -t
2022-04-11 20:45:45: Info: Selected mode: nvidia
2022-04-11 20:45:45: Info: Patching kernel line with nvidia-drm.modeset=1
2022-04-11 20:45:46: Info: Installing packages: nvidia-hook
2022-04-11 20:45:46: Info: Removing packages: lib32-nvidia-utils
    pacman -Rs --noconfirm --noprogressbar --nodeps lib32-nvidia-utils
    pacman -Syuq --noconfirm --noprogressbar --needed nvidia-hook
    grub-mkconfig -o /boot/grub/grub.cfg

I did some more research and found at that nvidia-hook was added to EndeavourOS a while ago.
I found this post and another post by @ricklinux talking about:

  • adding nvidia-drm.modeset=1 to /etc/default/grub
  • adding MODULES to mkinitcpio.conf
  • editing my 20-nvidia.conf file

and now I am completly lost.

Anyways I followed everything described in the post above (after a creating Timeshift Snapshot).

First of all I ran nvidia-inst and everything worked expect for an error telling me that the lib32-nvidia-utils package can actually not be removed because steam needs it. Is this a bug?

Then the nvidia-drm.modeset=1 & mkinitcpio.conf changes etc.

I did a reboot after every step but I noticed no changes and the DisplayPort issue still persists.

Following the 20-nvidia.conf part changed my maximum possible resolution to of 1600 x 900

…at this point of time I decided to roll back via Timeshift to my old Snapshot.

So now I have several questions:
Which of all those settings do I really need to set and configure?
Should I delete nvidia-installer-dkms and switch to nvidia-inst?
Do I need to install nvidia-hook?
Is nvidia-drm.modeset=1 in grub.cfg necessary? (I ask because it changed nothing for me)
Same for the MODULES part in mkinitcpio.conf
And the things in 20-nvidia.conf (which broke my screen resolution)

Thank you for your help!

You have many questions. I try to answer as many as I can, but some answers depend on what your hardware is.

Nvidia-inst is a new app and considered as beta quality, so it may have some problems. Hopefully not bad ones. We also keep the older nvidia-installer-dkms for now.

  • You could use the --32 option to keep the 32-bit package. Looks like nvidia-inst tries to be too aggressive on removing packages that it thinks are not needed. I will look into it in the coming days.
  • Nvidia-hook may not be needed on every Nvidia system. If you have no problems when managing (installing, upgrading, removing) Nvidia drivers without the hook, you can uninstall it. But it shouldn’t hurt to keep it.
  • Also the nvidia-drm.modeset=1 may not change anything, same happens here too. So if it doesn’t change anything, you can remove it or keep it. Some systems however seem to need it, that’s why nvidia-inst adds it.
  • The 20-nvidia.conf file is also something that (probably) is not needed. It comes from the history of nvidia-installer-dkms, and years ago it was considered useful (I think for bumblebee systems). You can probably remove it, but may be wise to have a backup if the system fails to boot without it.
  • The MODULES stuff is a bit vague to me. I have nothing in MODULES list, and my Nvidia works OK.
  • All in all, you could experiment with the various settings. I think the less modifications you have to do, the better.

There’s great information available:

In the good old days, turning the monitor on first then the computer was just how things were done. The computer needs to “talk” to the monitor to read it’s EDID preferred settings so the monitor needs to be on first.

So this might be a hardware problem with the Mother Board Display port or perhaps a BIOS/UEFI problem. Does your motherboard have the latest BIOS/UEFI installed?

Since this is a brand new monitor, maybe it’s version of EDID is newer than the EDID protocol on your mother board.


Thank you for your reply :slight_smile:

Currently / “by default” most of the things described in my post are actually not set. I just tried them out and used Timeshift to go back.

So I guess I just keep it that way because apart from my DisplaPort issue everthing works with my NVIDIA GPU. I’ll just install nvidia-hook since you said it shouldn’t hurt to keep it.

I played around with EDID for some hours but I could not get it working (and I broke a lot of things in the process).

(e.g.: adding Option “CustomEDID” “GPU-0.DFP-3:/etc/X11/edid.txt” after generating the EDID file for my monitor)

But I learned a lot about using tty3 CTRL+ALT+F3 in order to get a working system again - so at least it’s something that will help me in the future :slight_smile:!

I guess the easiest solution is to just turn on the monitor first :sweat_smile:.

1 Like

Actually I have a similar problem, but with my only monitor with HDMI cable. (With my previous HDMI monitor there was no problem.)
Switching to TTY temporarily solves the problem here as well. Or, simply waiting for a couple of minutes, but that’s too much for me… :wink: